summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-pyreadstat-link-libiconv.patch')
-rw-r--r--gnu/packages/patches/python-pyreadstat-link-libiconv.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-pyreadstat-link-libiconv.patch b/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
new file mode 100644
index 0000000000..7efd71faeb
--- /dev/null
+++ b/gnu/packages/patches/python-pyreadstat-link-libiconv.patch
@@ -0,0 +1,15 @@
+To ensure libiconv can be found by Guix, we need to link the library.
+
+--- a/setup.py
++++ b/setup.py
+@@ -81,8 +81,7 @@ else:
+ libraries.extend(["m", "z"])
+ _platform = sys.platform
+ # Mac: iconv needs to be linked statically
+- if _platform.lower().startswith("darwin"):
+- libraries.append("iconv")
++ libraries.append("iconv")
+
+ # Extensions
+ sources.sort()
+