summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/python-sip-include-dirs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/python-sip-include-dirs.patch')
-rw-r--r--gnu/packages/patches/python-sip-include-dirs.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/python-sip-include-dirs.patch b/gnu/packages/patches/python-sip-include-dirs.patch
new file mode 100644
index 0000000000..f2ef8fc1b2
--- /dev/null
+++ b/gnu/packages/patches/python-sip-include-dirs.patch
@@ -0,0 +1,20 @@
+Add an environment variable to python-sip that extends its search
+directories for .sip files.
+
+It seems that we cannot easily change the destination folder of these
+files though, so this variable must be set on a per-package basis (and
+non through search-path).
+
+--- sip/sipbuild/builder.py 2023-03-22 09:06:37.588792878 +0100
++++ sip/sipbuild/builder.py 2023-03-22 09:10:35.830181134 +0100
+@@ -254,6 +254,10 @@
+ os.path.join(project.target_dir,
+ project.get_bindings_dir()))
+
++ # Add extra bindings from environment for GNU Guix.
++ if 'SIP_INCLUDE_DIRS' in os.environ:
++ sip_include_dirs.extend(os.environ['SIP_INCLUDE_DIRS'].split(os.pathsep))
++
+ # Generate the sip.h file for the shared sip module.
+ copy_sip_h(abi_major_version, project.build_dir,
+ project.sip_module, version_info=project.version_info)