summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch')
-rw-r--r--gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch16
1 files changed, 0 insertions, 16 deletions
diff --git a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch b/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
deleted file mode 100644
index 4e801c3225..0000000000
--- a/gnu/packages/patches/ruby-concurrent-ignore-broken-test.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-This test appears to fail in GNU Guix and elsewhere. It has been reported
-upstream at https://github.com/puma/puma/issues/995
-
-diff --git a/spec/concurrent/channel_spec.rb b/spec/concurrent/channel_spec.rb
-index d70fba8..4f29a8b 100644
---- a/spec/concurrent/channel_spec.rb
-+++ b/spec/concurrent/channel_spec.rb
-@@ -598,7 +598,7 @@ module Concurrent
- }.to raise_error(ArgumentError)
- end
-
-- it 'loops until the block returns false' do
-+ xit 'loops until the block returns false' do
- actual = 0
- expected = 3
- latch = Concurrent::CountDownLatch.new(expected)