summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch')
-rw-r--r--gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch b/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
new file mode 100644
index 0000000000..106a6f5162
--- /dev/null
+++ b/gnu/packages/patches/scribus-1.5.8-poppler-22.09.0.patch
@@ -0,0 +1,20 @@
+--- a/scribus/plugins/import/pdf/slaoutput.cpp
++++ b/scribus/plugins/import/pdf/slaoutput.cpp
+@@ -3741,9 +3741,16 @@ void SlaOutputDev::getPenState(GfxState *state)
+ break;
+ }
+ double lw = state->getLineWidth();
+- double *dashPattern;
+ int dashLength;
++#if POPPLER_ENCODED_VERSION >= POPPLER_VERSION_ENCODE(22, 9, 0)
++ const double *dashPattern;
++ const std::vector<double> &dash = state->getLineDash(&DashOffset);
++ dashPattern = dash.data();
++ dashLength = dash.size();
++#else
++ double *dashPattern;
+ state->getLineDash(&dashPattern, &dashLength, &DashOffset);
++#endif
+ QVector<double> pattern(dashLength);
+ for (int i = 0; i < dashLength; ++i)
+ {