summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/tootle-reason-phrase.patch
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches/tootle-reason-phrase.patch')
-rw-r--r--gnu/packages/patches/tootle-reason-phrase.patch48
1 files changed, 0 insertions, 48 deletions
diff --git a/gnu/packages/patches/tootle-reason-phrase.patch b/gnu/packages/patches/tootle-reason-phrase.patch
deleted file mode 100644
index 72a1d1ecfa..0000000000
--- a/gnu/packages/patches/tootle-reason-phrase.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From 858ee78fbebe161a4cdd707a469dc0f045211a51 Mon Sep 17 00:00:00 2001
-From: Max Harmathy <harmathy@mailbox.org>
-Date: Wed, 25 Aug 2021 13:05:58 +0200
-Subject: [PATCH] Use reason_phrase instead of get_phrase
-
----
- src/Services/Cache.vala | 2 +-
- src/Services/Network.vala | 7 +------
- 2 files changed, 2 insertions(+), 7 deletions(-)
-
-diff --git a/src/Services/Cache.vala b/src/Services/Cache.vala
-index 2251697..2ed314e 100644
---- a/src/Services/Cache.vala
-+++ b/src/Services/Cache.vala
-@@ -88,7 +88,7 @@ public class Tootle.Cache : GLib.Object {
- try {
- var code = msg.status_code;
- if (code != Soup.Status.OK) {
-- var error = network.describe_error (code);
-+ var error = msg.reason_phrase;
- throw new Oopsie.INSTANCE (@"Server returned $error");
- }
-
-diff --git a/src/Services/Network.vala b/src/Services/Network.vala
-index fa2839c..d0143b0 100644
---- a/src/Services/Network.vala
-+++ b/src/Services/Network.vala
-@@ -56,7 +56,7 @@ public class Tootle.Network : GLib.Object {
- else if (status == Soup.Status.CANCELLED)
- debug ("Message is cancelled. Ignoring callback invocation.");
- else
-- ecb ((int32) status, describe_error ((int32) status));
-+ ecb ((int32) status, msg.reason_phrase);
- });
- }
- catch (Error e) {
-@@ -65,11 +65,6 @@ public class Tootle.Network : GLib.Object {
- }
- }
-
-- public string describe_error (uint code) {
-- var reason = Soup.Status.get_phrase (code);
-- return @"$code: $reason";
-- }
--
- public void on_error (int32 code, string message) {
- warning (message);
- app.toast (message);