summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch b/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
new file mode 100644
index 0000000000..a5bee60ac2
--- /dev/null
+++ b/gnu/packages/patches/kiwix-desktop-newer-libkiwix.patch
@@ -0,0 +1,40 @@
+Description: Fix building kiwix-desktop with libkiwix-12.1.0
+Bug: https://github.com/kiwix/kiwix-desktop/issues/964
+Origin: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
+Applied-Upstream: https://github.com/kiwix/kiwix-desktop/commit/1b322d8f01c787846546a6473f153cf1daa41e65
+---
+From 1b322d8f01c787846546a6473f153cf1daa41e65 Mon Sep 17 00:00:00 2001
+From: Matthieu Gautier <mgautier@kymeria.fr>
+Date: Thu, 9 Feb 2023 09:47:47 +0100
+Subject: [PATCH] With last version of libkiwix, Downloader now return
+ shared_ptr<Download>.
+
+---
+ src/contentmanager.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/contentmanager.cpp b/src/contentmanager.cpp
+index c2f4ff9..d4db50a 100644
+--- a/src/contentmanager.cpp
++++ b/src/contentmanager.cpp
+@@ -173,7 +173,7 @@ QStringList ContentManager::updateDownloadInfos(QString id, const QStringList &k
+ return values;
+ }
+ auto& b = mp_library->getBookById(id);
+- kiwix::Download* d;
++ std::shared_ptr<kiwix::Download> d;
+ try {
+ d = mp_downloader->getDownload(b.getDownloadId());
+ } catch(...) {
+@@ -270,7 +270,7 @@ QString ContentManager::downloadBook(const QString &id)
+ for (auto b : booksList)
+ if (b.toStdString() == book.getId())
+ return "";
+- kiwix::Download *download;
++ std::shared_ptr<kiwix::Download> download;
+ try {
+ std::pair<std::string, std::string> downloadDir("dir", downloadPath.toStdString());
+ const std::vector<std::pair<std::string, std::string>> options = { downloadDir };
+--
+2.41.0
+