summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch23
-rw-r--r--gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch75
2 files changed, 0 insertions, 98 deletions
diff --git a/gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch b/gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch
deleted file mode 100644
index f7b61391c3..0000000000
--- a/gnu/packages/patches/emacs-ess-fix-obsolete-function-alias.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-From 9cc5520e1998d03f5dec0fbb1fe71b7cdec38b65 Mon Sep 17 00:00:00 2001
-From: Alex Branham <alex.branham@gmail.com>
-Date: Wed, 6 Jan 2021 06:41:20 -0500
-Subject: [PATCH] Add required when to obsolete function alias
-
-Closes #1085
----
- lisp/ess-r-package.el | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/lisp/ess-r-package.el b/lisp/ess-r-package.el
-index 260959955..397ce14e6 100644
---- a/lisp/ess-r-package.el
-+++ b/lisp/ess-r-package.el
-@@ -577,7 +577,7 @@ package mode. Use this function if state of the buffer such as
- (error "As of ESS 16.04, `ess-developer' is deprecated. Use `ess-r-set-evaluation-env' instead"))
-
- (defalias 'ess-toggle-developer 'ess-developer)
--(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder)
-+(define-obsolete-function-alias 'ess-r-devtools-check-package-buildwin 'ess-r-devtools-check-with-winbuilder "18.04")
- (define-obsolete-function-alias 'ess-r-devtools-ask 'ess-r-devtools-execute-command "18.04")
-
- (make-obsolete-variable 'ess-developer "Please use `ess-developer-select-package' and `ess-r-set-evaluation-env' instead." "16.04")
diff --git a/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch b/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch
deleted file mode 100644
index 65ace2ee5e..0000000000
--- a/gnu/packages/patches/emacs-haskell-mode-no-redefine-builtin.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From faa95a784d2c74c72e70367a5d531df6dd61aeab Mon Sep 17 00:00:00 2001
-From: Steve Purcell <steve@sanityinc.com>
-Date: Sun, 6 Aug 2023 16:41:48 +0200
-Subject: [PATCH] Don't redefine built-in function
-
-Fixes #1817
----
- tests/haskell-indent-tests.el | 14 ++++++++------
- tests/haskell-indentation-tests.el | 14 ++++++++------
- 2 files changed, 16 insertions(+), 12 deletions(-)
-
-diff --git a/tests/haskell-indent-tests.el b/tests/haskell-indent-tests.el
-index 7196405b8..9a3de4ad3 100644
---- a/tests/haskell-indent-tests.el
-+++ b/tests/haskell-indent-tests.el
-@@ -40,11 +40,13 @@
- ;; (haskell-indent-put-region-in-literate (point-min) (point-max) -1)
- ;; (buffer-substring-no-properties (point-min) (point-max))))))
-
--(defsubst string-trim-left (string)
-- "Remove leading whitespace from STRING."
-- (if (string-match "\\`[ \t\n\r]+" string)
-- (replace-match "" t t string)
-- string))
-+(if (fboundp 'string-trim-left)
-+ (defalias 'haskell--string-trim-left 'string-trim-left)
-+ (defun haskell--string-trim-left (string &optional regexp)
-+ "Remove leading whitespace from STRING."
-+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
-+ (substring string (match-end 0))
-+ string)))
-
- (defun haskell-indent-format-info (info)
- (if (cdr info)
-@@ -128,7 +130,7 @@ macro quotes them for you."
- :expected-result
- ,(if allow-failure :failed :passed)
- (haskell-indent-check
-- ,(string-trim-left source)
-+ ,(haskell--string-trim-left source)
- ,@(mapcar (lambda (x)
- (list 'quote x))
- test-cases))))))
-diff --git a/tests/haskell-indentation-tests.el b/tests/haskell-indentation-tests.el
-index 4889b76a7..cd783a4f4 100644
---- a/tests/haskell-indentation-tests.el
-+++ b/tests/haskell-indentation-tests.el
-@@ -33,11 +33,13 @@
-
- ;;; Code:
-
--(defsubst string-trim-left (string)
-- "Remove leading whitespace from STRING."
-- (if (string-match "\\`[ \t\n\r]+" string)
-- (replace-match "" t t string)
-- string))
-+(if (fboundp 'string-trim-left)
-+ (defalias 'haskell--string-trim-left 'string-trim-left)
-+ (defun haskell--string-trim-left (string &optional regexp)
-+ "Remove leading whitespace from STRING."
-+ (if (string-match (concat "\\`\\(?:" (or regexp "[ \t\n\r]+") "\\)") string)
-+ (substring string (match-end 0))
-+ string)))
-
- (defun haskell-indentation-check (source &rest test-cases)
- "Check if `haskell-indentation-find-indentations' returns expected results.
-@@ -115,7 +117,7 @@ macro quotes them for you."
- :expected-result
- ,(if allow-failure :failed :passed)
- (haskell-indentation-check
-- ,(string-trim-left source)
-+ ,(haskell--string-trim-left source)
- ,@(mapcar (lambda (x)
- (list 'quote x))
- test-cases))))))