summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/gdm-default-session.patch91
-rw-r--r--gnu/packages/patches/libvpx-use-after-free-in-postproc.patch34
-rw-r--r--gnu/packages/patches/python-jedi-deleted-variables.patch38
-rw-r--r--gnu/packages/patches/txr-shell.patch59
4 files changed, 91 insertions, 131 deletions
diff --git a/gnu/packages/patches/gdm-default-session.patch b/gnu/packages/patches/gdm-default-session.patch
new file mode 100644
index 0000000000..4839a04de4
--- /dev/null
+++ b/gnu/packages/patches/gdm-default-session.patch
@@ -0,0 +1,91 @@
+This patch ensures '.desktop' files are picked up in the system profile
+and not in the directories listed in $XDG_DATA_DIRS. The latter includes
+'gnome-session.desktop', which should be used if it's in
+/run/current-system/profile, and only then.
+
+Fixes <https://bugs.gnu.org/37831>.
+
+diff --git a/daemon/gdm-session.c b/daemon/gdm-session.c
+index 6a116a8..02c1458 100644
+--- a/daemon/gdm-session.c
++++ b/daemon/gdm-session.c
+@@ -348,24 +348,18 @@ get_system_session_dirs (GdmSession *self)
+ GArray *search_array = NULL;
+ char **search_dirs;
+ int i;
+- const gchar * const *system_data_dirs = g_get_system_data_dirs ();
+
+ static const char *x_search_dirs[] = {
+ "/etc/X11/sessions/",
+ DMCONFDIR "/Sessions/",
+ DATADIR "/gdm/BuiltInSessions/",
+- DATADIR "/xsessions/",
++ "/run/current-system/profile/share/xsessions/"
+ };
+
+ static const char *wayland_search_dir = DATADIR "/wayland-sessions/";
+
+ search_array = g_array_new (TRUE, TRUE, sizeof (char *));
+
+- for (i = 0; system_data_dirs[i]; i++) {
+- gchar *dir = g_build_filename (system_data_dirs[i], "xsessions", NULL);
+- g_array_append_val (search_array, dir);
+- }
+-
+ g_array_append_vals (search_array, x_search_dirs, G_N_ELEMENTS (x_search_dirs));
+
+ #ifdef ENABLE_WAYLAND_SUPPORT
+@@ -373,16 +367,7 @@ get_system_session_dirs (GdmSession *self)
+ #ifdef ENABLE_USER_DISPLAY_SERVER
+ g_array_prepend_val (search_array, wayland_search_dir);
+
+- for (i = 0; system_data_dirs[i]; i++) {
+- gchar *dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
+- g_array_insert_val (search_array, i, dir);
+- }
+ #else
+- for (i = 0; system_data_dirs[i]; i++) {
+- gchar *dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
+- g_array_append_val (search_array, dir);
+- }
+-
+ g_array_append_val (search_array, wayland_search_dir);
+ #endif
+ }
+diff --git a/libgdm/gdm-sessions.c b/libgdm/gdm-sessions.c
+index afbc5c0..bb5e3e6 100644
+--- a/libgdm/gdm-sessions.c
++++ b/libgdm/gdm-sessions.c
+@@ -238,19 +238,11 @@ collect_sessions (void)
+ "/etc/X11/sessions/",
+ DMCONFDIR "/Sessions/",
+ DATADIR "/gdm/BuiltInSessions/",
+- DATADIR "/xsessions/",
+- NULL
++ "/run/current-system/profile/share/xsessions/"
+ };
+
+ xorg_search_array = g_array_new (TRUE, TRUE, sizeof (char *));
+
+- const gchar * const *system_data_dirs = g_get_system_data_dirs ();
+-
+- for (i = 0; system_data_dirs[i]; i++) {
+- session_dir = g_build_filename (system_data_dirs[i], "xsessions", NULL);
+- g_array_append_val (xorg_search_array, session_dir);
+- }
+-
+ g_array_append_vals (xorg_search_array, xorg_search_dirs, G_N_ELEMENTS (xorg_search_dirs));
+
+ #ifdef ENABLE_WAYLAND_SUPPORT
+@@ -261,11 +253,6 @@ collect_sessions (void)
+
+ wayland_search_array = g_array_new (TRUE, TRUE, sizeof (char *));
+
+- for (i = 0; system_data_dirs[i]; i++) {
+- session_dir = g_build_filename (system_data_dirs[i], "wayland-sessions", NULL);
+- g_array_append_val (wayland_search_array, session_dir);
+- }
+-
+ g_array_append_vals (wayland_search_array, wayland_search_dirs, G_N_ELEMENTS (wayland_search_dirs));
+ #endif
+
diff --git a/gnu/packages/patches/libvpx-use-after-free-in-postproc.patch b/gnu/packages/patches/libvpx-use-after-free-in-postproc.patch
deleted file mode 100644
index 04f2a953b7..0000000000
--- a/gnu/packages/patches/libvpx-use-after-free-in-postproc.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-From 52add5896661d186dec284ed646a4b33b607d2c7 Mon Sep 17 00:00:00 2001
-From: Jerome Jiang <jianj@google.com>
-Date: Wed, 23 May 2018 15:43:00 -0700
-Subject: [PATCH] VP8: Fix use-after-free in postproc.
-
-The pointer in vp8 postproc refers to show_frame_mi which is only
-updated on show frame. However, when there is a no-show frame which also
-changes the size (thus new frame buffers allocated), show_frame_mi is
-not updated with new frame buffer memory.
-
-Change the pointer in postproc to mi which is always updated.
-
-Bug: 842265
-Change-Id: I33874f2112b39f74562cba528432b5f239e6a7bd
----
- vp8/common/postproc.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/vp8/common/postproc.c b/vp8/common/postproc.c
-index d67ee8a57..8c292d616 100644
---- a/vp8/common/postproc.c
-+++ b/vp8/common/postproc.c
-@@ -65,7 +65,7 @@ void vp8_deblock(VP8_COMMON *cm, YV12_BUFFER_CONFIG *source,
- double level = 6.0e-05 * q * q * q - .0067 * q * q + .306 * q + .0065;
- int ppl = (int)(level + .5);
-
-- const MODE_INFO *mode_info_context = cm->show_frame_mi;
-+ const MODE_INFO *mode_info_context = cm->mi;
- int mbr, mbc;
-
- /* The pixel thresholds are adjusted according to if or not the macroblock
---
-2.19.0
-
diff --git a/gnu/packages/patches/python-jedi-deleted-variables.patch b/gnu/packages/patches/python-jedi-deleted-variables.patch
deleted file mode 100644
index 53bdc05cde..0000000000
--- a/gnu/packages/patches/python-jedi-deleted-variables.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Fix test failure in some environments, including Guix.
-
-Taken from upstream:
-https://github.com/davidhalter/jedi/commit/bec87f7ff82b0731713c6520a14c213341b4cecf
-
-diff --git a/test/completion/basic.py b/test/completion/basic.py
-index b40068179..3ff919ca6 100644
---- a/test/completion/basic.py
-+++ b/test/completion/basic.py
-@@ -209,11 +209,11 @@ def global_as_import():
-
- deleted_var = 3
- del deleted_var
--#? int()
-+#?
- deleted_var
--#? ['deleted_var']
-+#? []
- deleted_var
--#! ['deleted_var = 3']
-+#! []
- deleted_var
-
- # -----------------
-diff --git a/test/test_api/test_full_name.py b/test/test_api/test_full_name.py
-index 4fdb861b0..6858b6ca8 100644
---- a/test/test_api/test_full_name.py
-+++ b/test/test_api/test_full_name.py
-@@ -112,7 +112,8 @@ def test_os_path(Script):
-
- def test_os_issues(Script):
- """Issue #873"""
-- assert [c.name for c in Script('import os\nos.nt''').complete()] == ['nt']
-+ # nt is not found, because it's deleted
-+ assert [c.name for c in Script('import os\nos.nt''').complete()] == []
-
-
- def test_param_name(Script):
diff --git a/gnu/packages/patches/txr-shell.patch b/gnu/packages/patches/txr-shell.patch
deleted file mode 100644
index a4abb73eac..0000000000
--- a/gnu/packages/patches/txr-shell.patch
+++ /dev/null
@@ -1,59 +0,0 @@
-Use the current shell instead of trying to find another one and
-failing to do so.
-
-diff --git a/configure b/configure
-index f1adb919..7891b4dc 100755
---- a/configure
-+++ b/configure
-@@ -26,28 +26,6 @@
- # OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
- # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
--#
--# The #!/bin/sh might be some legacy piece of crap,
--# not even up to 1990 POSIX.2 spec. So the first step
--# is to look for a better shell in some known places
--# and re-execute ourselves with that interpreter.
--#
--
--if test x$txr_shell = x ; then
-- for shell in /bin/bash /usr/bin/bash /usr/xpg4/bin/sh ; do
-- if test -x $shell ; then
-- txr_shell=$shell
-- break
-- fi
-- done
-- if test x$txr_shell = x ; then
-- echo "No known POSIX shell found: falling back on /bin/sh, which may not work"
-- txr_shell=/bin/sh
-- fi
-- export txr_shell
-- exec $txr_shell $0 ${@+"$@"}
--fi
--
- set -u
-
- #
-@@ -190,13 +168,6 @@ while [ $# -gt 0 ] ; do
- exit 1
- fi
-
-- eval "var_exists=\${$var+y}"
--
-- if [ "$var_exists" != y ] ; then
-- printf "$0: nonexistent option: '%s'\n" "$1"
-- exit 1
-- fi
--
- eval "$var='$val'"
-
- eval "var_given_exists=\${${var}_given+y}"
-@@ -208,6 +179,8 @@ while [ $# -gt 0 ] ; do
- shift
- done
-
-+txr_shell=$CONFIG_SHELL
-+
- #
- # If --help was given (or --help=<nonempty> or help=<nonempty>) then
- # print help and exit. The termination status is failed, to indicate