summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/coreutils-dummy-man.patch10
-rw-r--r--gnu/packages/patches/coreutils-skip-nohup.patch28
-rw-r--r--gnu/packages/patches/file-CVE-2014-3587.patch16
-rw-r--r--gnu/packages/patches/libffi-mips-n32-fix.patch21
4 files changed, 21 insertions, 54 deletions
diff --git a/gnu/packages/patches/coreutils-dummy-man.patch b/gnu/packages/patches/coreutils-dummy-man.patch
index f6a6a31002..a43cfc47c3 100644
--- a/gnu/packages/patches/coreutils-dummy-man.patch
+++ b/gnu/packages/patches/coreutils-dummy-man.patch
@@ -7,15 +7,15 @@ would appear when compiling:
dummy-man: too many non-option arguments
---- coreutils-8.22/Makefile.in 2013-12-13 16:20:00.000000000 +0100
-+++ coreutils-8.22/Makefile.in 2014-02-28 10:53:27.000000000 +0100
-@@ -9977,8 +9977,8 @@ man/yes.1: src/yes
+--- coreutils-8.23/Makefile.in 2014-07-18 18:22:24.000000000 -0400
++++ coreutils-8.23/Makefile.in 2014-08-03 20:21:10.849158313 -0400
+@@ -14076,8 +14076,8 @@
&& $(run_help2man) \
--source='$(PACKAGE_STRING)' \
--include=$(srcdir)/man/$$name.x \
-- --output=$$t/$$name.1 $$t/$$name \
+- --output=$$t/$$name.1 $$t/$$argv \
--info-page='coreutils \(aq'$$name' invocation\(aq' \
-+ --output=$$t/$$name.1 $$t/$$name \
++ --output=$$t/$$name.1 $$t/$$argv \
&& sed \
-e 's|$*\.td/||g' \
-e '/For complete documentation/d' \
diff --git a/gnu/packages/patches/coreutils-skip-nohup.patch b/gnu/packages/patches/coreutils-skip-nohup.patch
deleted file mode 100644
index f5283a6b21..0000000000
--- a/gnu/packages/patches/coreutils-skip-nohup.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-commit 5dce6bdfafc930dfd17d5d16aea7d1add3472066
-Author: Pádraig Brady <P@draigBrady.com>
-Date: Wed Mar 5 15:14:07 2014 +0000
-
- tests: fix false failure in nohup.sh in non tty builds
-
- * tests/misc/nohup.sh: When running tests without a controlling tty,
- an exec failure is triggered in a subshell, which causes POSIX
- shells to immediately exit the subshell. This was brought
- to notice by the newly conforming bash 4.3.
- Fixes http:/bugs.gnu.org/16940
-
-diff --git a/tests/misc/nohup.sh b/tests/misc/nohup.sh
-index 6d2b515..2328b43 100755
---- a/tests/misc/nohup.sh
-+++ b/tests/misc/nohup.sh
-@@ -63,6 +63,11 @@ rm -f nohup.out err
- # to stderr must be fatal. Requires stdout to be terminal.
- if test -w /dev/full && test -c /dev/full; then
- (
-+ # POSIX shells immediately exit the subshell on exec error.
-+ # So check we can write to /dev/tty before the exec, which
-+ # isn't possible if we've no controlling tty for example.
-+ test -c /dev/tty && >/dev/tty || exit 0
-+
- exec >/dev/tty
- test -t 1 || exit 0
- nohup echo hi 2> /dev/full
diff --git a/gnu/packages/patches/file-CVE-2014-3587.patch b/gnu/packages/patches/file-CVE-2014-3587.patch
new file mode 100644
index 0000000000..cf88bf5f3e
--- /dev/null
+++ b/gnu/packages/patches/file-CVE-2014-3587.patch
@@ -0,0 +1,16 @@
+Fixes CVE-2014-3587. Copied from upstream commit
+0641e56be1af003aa02c7c6b0184466540637233.
+
+--- file-5.19/src/cdf.c.orig 2014-06-09 09:04:37.000000000 -0400
++++ file-5.19/src/cdf.c 2014-08-26 11:55:23.887118898 -0400
+@@ -824,6 +824,10 @@
+ q = (const uint8_t *)(const void *)
+ ((const char *)(const void *)p + ofs
+ - 2 * sizeof(uint32_t));
++ if (q < p) {
++ DPRINTF(("Wrapped around %p < %p\n", q, p));
++ goto out;
++ }
+ if (q > e) {
+ DPRINTF(("Ran of the end %p > %p\n", q, e));
+ goto out;
diff --git a/gnu/packages/patches/libffi-mips-n32-fix.patch b/gnu/packages/patches/libffi-mips-n32-fix.patch
deleted file mode 100644
index 87ec48f883..0000000000
--- a/gnu/packages/patches/libffi-mips-n32-fix.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-Fix handling of uint32_t arguments on the MIPS N32 ABI.
-
-Patch by Mark H Weaver <mhw@netris.org>.
-
---- libffi/src/mips/ffi.c.orig 2013-03-16 07:19:39.000000000 -0400
-+++ libffi/src/mips/ffi.c 2013-10-22 01:11:03.111985247 -0400
-@@ -170,7 +170,14 @@
- break;
-
- case FFI_TYPE_UINT32:
-+#ifdef FFI_MIPS_N32
-+ /* The N32 ABI requires that 32-bit integers
-+ be sign-extended to 64-bits, regardless of
-+ whether they are signed or unsigned. */
-+ *(ffi_arg *)argp = *(SINT32 *)(* p_argv);
-+#else
- *(ffi_arg *)argp = *(UINT32 *)(* p_argv);
-+#endif
- break;
-
- /* This can only happen with 64bit slots. */