summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/mutt-store-references.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/patches/mutt-store-references.patch b/gnu/packages/patches/mutt-store-references.patch
new file mode 100644
index 0000000000..3b69c7b0bd
--- /dev/null
+++ b/gnu/packages/patches/mutt-store-references.patch
@@ -0,0 +1,16 @@
+By default 'mutt' embeds configure flags and the output of 'gcc -v',
+which contains the store file name of Bash and GCC. This patch makes
+sure we don't embed a reference to these in 'mutt'.
+
+--- mutt-1.5.23/txt2c.sh 2015-06-26 22:56:56.500731643 +0200
++++ mutt-1.5.23/txt2c.sh 2015-06-26 22:57:26.664583900 +0200
+@@ -21,6 +21,8 @@ txt2c_fallback () {
+ echo ";"
+ }
+
++echo "unsigned char $1[] = \"value of '$1' not kept\";"
++exit 0
+ ./txt2c test </dev/null >/dev/null 2>&1 &&
+ ./txt2c "$1" ||
+ txt2c_fallback "$1"
+