summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 0324a21261..10e29cf6ca 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -33,6 +33,7 @@
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix utils)
#:use-module (guix build-system gnu))
(define-public pcre
@@ -62,7 +63,9 @@
"--enable-pcre16"
"--enable-pcre32"
;; pcretest fails on powerpc32.
- ,@(if (target-ppc32?)
+ ;; riscv64-linux is an unsupported architecture.
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
'()
`("--enable-jit")))
#:phases (modify-phases %standard-phases
@@ -106,7 +109,9 @@ POSIX regular expression API.")
"--enable-pcre2-16"
"--enable-pcre2-32"
;; pcre2_jit_test fails on powerpc32.
- ,@(if (target-ppc32?)
+ ;; riscv64-linux is an unsupported architecture.
+ ,@(if (or (target-ppc32?)
+ (target-riscv64?))
'()
`("--enable-jit"))
"--disable-static")