summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm10
1 files changed, 1 insertions, 9 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index 58beab0a96..61aaf7c153 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -34,7 +34,6 @@
(package
(name "pcre")
(version "8.40")
- (replacement pcre/fixed)
(source (origin
(method url-fetch)
(uri (list
@@ -43,6 +42,7 @@
"pcre-" version ".tar.bz2")
(string-append "mirror://sourceforge/pcre/pcre/"
version "/pcre-" version ".tar.bz2")))
+ (patches (search-patches "pcre-CVE-2017-7186.patch"))
(sha256
(base32
"1x7lpjn7jhk0n3sdvggxrlrhab8kkfjwl7qix0ypw9nlx8lpmqh0"))))
@@ -72,14 +72,6 @@ POSIX regular expression API.")
(license license:bsd-3)
(home-page "http://www.pcre.org/")))
-(define pcre/fixed
- (package
- (inherit pcre)
- (replacement #f)
- (source (origin
- (inherit (package-source pcre))
- (patches (search-patches "pcre-CVE-2017-7186.patch"))))))
-
(define-public pcre2
(package
(name "pcre2")