summaryrefslogtreecommitdiff
path: root/gnu/packages/pcre.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pcre.scm')
-rw-r--r--gnu/packages/pcre.scm22
1 files changed, 8 insertions, 14 deletions
diff --git a/gnu/packages/pcre.scm b/gnu/packages/pcre.scm
index bc0e285001..318727915e 100644
--- a/gnu/packages/pcre.scm
+++ b/gnu/packages/pcre.scm
@@ -37,18 +37,14 @@
(define-public pcre
(package
(name "pcre")
- (version "8.44")
+ (version "8.45")
(source (origin
(method url-fetch)
- (uri (list
- (string-append "ftp://ftp.csx.cam.ac.uk"
- "/pub/software/programming/pcre/"
- "pcre-" version ".tar.bz2")
- (string-append "mirror://sourceforge/pcre/pcre/"
- version "/pcre-" version ".tar.bz2")))
+ (uri (string-append "https://ftp.pcre.org/pub/pcre/pcre-"
+ version ".tar.bz2"))
(sha256
(base32
- "0v9nk51wh55pcbnf2jr36yarz8ayajn6d7ywiq2wagivn9c8c40r"))))
+ "1f7zichy6iimmkfrqdl575sdlm795cyc75szgg1vc2xvsbf6zbjd"))))
(build-system gnu-build-system)
(outputs '("out" ;library & headers
"bin" ;depends on Readline (adds 20MiB to the closure)
@@ -77,8 +73,7 @@
(link lib (string-append static "/"
(basename lib)))
(delete-file lib))
- (find-files source "\\.a$"))
- #t))))))
+ (find-files source "\\.a$"))))))))
(synopsis "Perl Compatible Regular Expressions")
(description
"The PCRE library is a set of functions that implement regular expression
@@ -91,14 +86,14 @@ POSIX regular expression API.")
(define-public pcre2
(package
(name "pcre2")
- (version "10.35")
+ (version "10.37")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/pcre/pcre2/"
version "/pcre2-" version ".tar.bz2"))
(sha256
(base32
- "04s6kmk9qdd4rjz477h547j4bx7hfz0yalpvrm381rqc5ghaijww"))))
+ "0w6jaswjmg3bc0wsw6msn5bvk66p90kf2asnnj9rhll0idpak5ad"))))
(build-system gnu-build-system)
(inputs `(("bzip2" ,bzip2)
("readline" ,readline)
@@ -117,8 +112,7 @@ POSIX regular expression API.")
(add-after 'unpack 'patch-paths
(lambda _
(substitute* "RunGrepTest"
- (("/bin/echo") (which "echo")))
- #t)))))
+ (("/bin/echo") (which "echo"))))))))
(synopsis "Perl Compatible Regular Expressions")
(description
"The PCRE library is a set of functions that implement regular expression