summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm19
1 files changed, 13 insertions, 6 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 029eafc010..378655a70f 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -17,7 +17,7 @@
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2019 Ben Sturmfels <ben@sturm.com.au>
;;; Copyright © 2019,2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
-;;; Copyright © 2020-2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020-2023 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2020, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
@@ -341,10 +341,14 @@ please install the @code{flyer-composer-gui} package.")))
;; different solution to the circular dependency mentioned above.
(list glib))
(native-inputs
+ (append
(list pkg-config
`(,glib "bin") ; glib-mkenums, etc.
gobject-introspection
- python))
+ python)
+ (if (%current-target-system)
+ (list pkg-config-for-build)
+ '())))
(arguments
(list
;; The Poppler test suite needs to be downloaded separately and contains
@@ -999,7 +1003,7 @@ using a stylus.")
(define-public xournalpp
(package
(name "xournalpp")
- (version "1.1.3")
+ (version "1.2.1")
(source
(origin
(method git-fetch)
@@ -1008,11 +1012,11 @@ using a stylus.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "17qq3clfmiyrcah89h8c5r6pc58xcskm5z1czbasv67bfq7chzhy"))))
+ (base32 "18slm517yazysvd0ii0gi7kg4hzyf17d86w2bflgfaz9ccclswbn"))))
(build-system cmake-build-system)
(arguments
(list
- #:configure-flags #~(list "-DENABLE_CPPUNIT=ON") ;enable tests
+ #:configure-flags #~(list "-DENABLE_GTEST=ON")
#:imported-modules `((guix build glib-or-gtk-build-system)
,@%cmake-build-system-modules)
#:modules '(((guix build glib-or-gtk-build-system) #:prefix glib-or-gtk:)
@@ -1029,10 +1033,13 @@ using a stylus.")
(string-append "\""
(search-input-file inputs "/bin/addr2line")
" ")))))
+ (add-after 'build 'prepare-tests
+ (lambda _
+ (invoke "cmake" "--build" "." "--target" "test-units")))
(add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))))
(native-inputs
- (list cppunit gettext-minimal help2man pkg-config))
+ (list cppunit gettext-minimal googletest help2man pkg-config))
(inputs
(list alsa-lib
gtk+