summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm60
1 files changed, 30 insertions, 30 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 8c28c94ed9..ff387354e7 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
-;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018, 2019 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;;
@@ -387,7 +387,7 @@ error when it would have happened.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/R/RG/RGARCIA/"
+ (uri (string-append "mirror://cpan/authors/id/R/RJ/RJBS/"
"base-" version ".tar.gz"))
(sha256
(base32 "1pjxcbbcpwlgzm0fzsbqd58zn8cj9vwril1wn3xfd7ws550mixa0"))))
@@ -733,7 +733,7 @@ to test the installed perl for compatibility with his modules.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/R/RJ/RJBS/Carp-"
+ "mirror://cpan/authors/id/X/XS/XSAWYERX/Carp-"
version ".tar.gz"))
(sha256
(base32
@@ -821,7 +821,7 @@ Perl.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/K/KE/KENTNL/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"Carp-Clan-" version ".tar.gz"))
(sha256
(base32
@@ -911,7 +911,7 @@ the same mk_accessors interface.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/R/RI/RIBASUSHI/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Class-Accessor-Grouped-" version ".tar.gz"))
(sha256
(base32 "1fy48hx56n5kdn1gz66awg465qf34r0n5jam64x7zxh9zhzb1m9m"))))
@@ -981,7 +981,7 @@ supporting the same interface, but using Class::C3 to do the hard work.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/F/FR/FREW/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"Class-C3-Componentised-" version ".tar.gz"))
(sha256
(base32 "14wn1g45z3b5apqq7dcai5drk01hfyqydsd2m6hsxzhyvi3b2l9h"))))
@@ -1027,7 +1027,7 @@ subclasses and can be overridden.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/S/SZ/SZABGAB/"
+ (uri (string-append "mirror://cpan/authors/id/Y/YA/YANICK/"
"Class-Date-" version ".tar.gz"))
(sha256
(base32 "1h7dfjxkpqbfymrf1bn7699i4fx6pbv5wvvi5zszfr8sqqkax1yf"))))
@@ -1190,11 +1190,11 @@ write accessor methods for your objects that perform standard tasks.")
("perl-test-requires" ,perl-test-requires)))
(home-page "https://metacpan.org/release/Class-Method-Modifiers")
(synopsis "Moose-like method modifiers")
- (description "Class::Method::Modifiers provides three modifiers: 'before',
-'around', and 'after'. 'before' and 'after' are run just before and after the
-method they modify, but can not really affect that original method. 'around'
-is run in place of the original method, with a hook to easily call that
-original method.")
+ (description "Class::Method::Modifiers provides three modifiers:
+@code{before}, @code{around}, and @code{after}. @code{before} and @code{after}
+are run just before and after the method they modify, but can not really affect
+that original method. @code{around} is run in place of the original method,
+with a hook to easily call that original method.")
(license (package-license perl))))
(define-public perl-class-singleton
@@ -2216,7 +2216,7 @@ time before its creation (in 1582).")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/P/PI/PIJLL/"
+ (uri (string-append "mirror://cpan/authors/id/W/WY/WYANT/"
"DateTime-Calendar-Julian-" version ".tar.gz"))
(sha256
(base32 "0gbw7rh706qk5jlmmz3yzsm0ilzp39kyar28g4j6d57my8cwaipx"))))
@@ -2938,7 +2938,7 @@ input a message of arbitrary length and produces as output a
(build-system perl-build-system)
(synopsis "Perl implementation of the SHA-1 message digest algorithm")
(description
- "This package provides 'Digest::SHA1', an implementation of the NIST
+ "This package provides @code{Digest::SHA1}, an implementation of the NIST
SHA-1 message digest algorithm for use by Perl programs.")
(home-page "https://metacpan.org/release/Digest-SHA1")
(license (package-license perl))))
@@ -3481,7 +3481,7 @@ provide a quick dropin when such functionality is needed.")
(home-page "https://metacpan.org/release/File-HomeDir")
(synopsis "Find your home and other directories on any platform")
(description "File::HomeDir is a module for locating the directories that
-are \"owned\" by a user (typically your user) and to solve the various issues
+are @code{owned} by a user (typically your user) and to solve the various issues
that arise trying to find them consistently across a wide variety of
platforms.")
(license (package-license perl))))
@@ -3747,7 +3747,7 @@ slurping and spewing. All functions are optionally exported.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"File-Temp-" version ".tar.gz"))
(sha256
(base32 "0pr3wrxrk93wy7dz9gsb1sgl77icrs8rh2mah6wms5cdi2ll5ch1"))))
@@ -4266,8 +4266,8 @@ filehandles; in particular, IO::Scalar, IO::ScalarArray, and IO::Lines.")
(home-page "https://metacpan.org/release/IO-Tty")
(synopsis "Perl interface to pseudo ttys")
(description
- "This package provides the 'IO::Pty' and 'IO::Tty' Perl interfaces to
-pseudo ttys.")
+ "This package provides the @code{IO::Pty} and @code{IO::Tty} Perl
+interfaces to pseudo ttys.")
(license (package-license perl))))
(define-public perl-ipc-cmd
@@ -4515,7 +4515,7 @@ versa.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/Log-Any-"
+ (uri (string-append "mirror://cpan/authors/id/P/PR/PREACTION/Log-Any-"
version ".tar.gz"))
(sha256
(base32 "1wb55ib4gvk8h5pjb6hliqg7li1xjk420q3w5r33f9p1ps60ylbl"))))
@@ -4533,7 +4533,7 @@ application, in turn, may choose one or more logging mechanisms via
@code{Log::Any} has a very tiny footprint and no dependencies beyond Perl
itself, which makes it appropriate for even small CPAN modules to use. It
-defaults to 'null' logging activity, so a module can safely log without
+defaults to @code{null} logging activity, so a module can safely log without
worrying about whether the application has chosen (or will ever choose) a
logging mechanism.")
(license (package-license perl))))
@@ -4606,7 +4606,7 @@ widely popular (Java-based) Log4j logging package in pure Perl.")
"This module allows libraries to have a dependency to a small module
instead of the full Log-Report distribution. The full power of
@code{Log::Report} is only released when the main program uses that module.
-In that case, the module using the 'Optional' will also use the full
+In that case, the module using the @code{Optional} will also use the full
@code{Log::Report}, otherwise the dressed-down @code{Log::Report::Minimal}
version.")
(license (package-license perl))))
@@ -5274,7 +5274,7 @@ examine the contents, and perform some simple tasks. It can also load the
(home-page "https://metacpan.org/release/Module-Pluggable")
(synopsis "Give your Perl module the ability to have plugins")
(description "This module provides a simple but extensible way of having
-'plugins' for your Perl module.")
+@code{plugins} for your Perl module.")
(license (package-license perl))))
(define-public perl-module-runtime
@@ -5516,7 +5516,7 @@ sentences.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/F/FL/FLORA/"
+ (uri (string-append "mirror://cpan/authors/id/H/HA/HAARG/"
"MooseX-Emulate-Class-Accessor-Fast-"
version ".tar.gz"))
(sha256
@@ -6226,7 +6226,7 @@ fields in Moo-based classes.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/S/SY/SYOHEX/Mouse-v"
+ "mirror://cpan/authors/id/S/SK/SKAJI/Mouse-v"
version
".tar.gz"))
(sha256
@@ -6540,7 +6540,7 @@ number exists in a given range, and to be able to manipulate the range.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"Object-Signature-" version ".tar.gz"))
(sha256
(base32 "12k90c19ly93ib1p6sm3k7sbnr2h5dbywkdmnff2ngm99p4m68c4"))))
@@ -6635,7 +6635,7 @@ one or more modules.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"Package-Stash-" version ".tar.gz"))
(sha256
(base32 "0zrs4byhlpq5ybnl0fd3y6pfzair6i2dyvzn7f7a7pgj9n2fi3n5"))))
@@ -6663,7 +6663,7 @@ of that behind a simple API.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/D/DO/DOY/"
+ (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
"Package-Stash-XS-" version ".tar.gz"))
(sha256
(base32 "1akqk10qxwk798qppajqbczwmhy4cs9g0lg961m3vq218slnnryk"))))
@@ -7130,7 +7130,7 @@ of @code{ref}.")
(build-system perl-build-system)
(synopsis "Provide commonly requested regular expressions")
(description
- "This module exports a single hash (`%RE') that stores or generates
+ "This module exports a single hash (@code{%RE}) that stores or generates
commonly needed regular expressions. Patterns currently provided include:
balanced parentheses and brackets, delimited text (with escapes), integers and
floating-point numbers in any base (up to 36), comments in 44 languages,
@@ -7790,7 +7790,7 @@ support for run-time mix-ins and roles.")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/S/SZ/SZABGAB/SVG-"
+ (uri (string-append "mirror://cpan/authors/id/M/MA/MANWAR/SVG-"
version ".tar.gz"))
(sha256
(base32 "1br8dwh2363s6r0qgy7vv30gv5kj456vj5m6x83savx4wzfnsggc"))))
@@ -8612,7 +8612,7 @@ duration strings like \"2 minutes\" and \"3 seconds\" to seconds.")
(source (origin
(method url-fetch)
(uri (string-append
- "mirror://cpan/authors/id/J/JH/JHI/Time-HiRes-"
+ "mirror://cpan/authors/id/A/AT/ATOOMIC/Time-HiRes-"
version ".tar.gz"))
(sha256
(base32