summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm55
1 files changed, 31 insertions, 24 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index c4d9d64de3..073cdbf482 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -3431,7 +3431,7 @@ provide a quick dropin when such functionality is needed.")
(define-public perl-file-homedir
(package
(name "perl-file-homedir")
- (version "1.002")
+ (version "1.004")
(source
(origin
(method url-fetch)
@@ -3439,7 +3439,7 @@ provide a quick dropin when such functionality is needed.")
"File-HomeDir-" version ".tar.gz"))
(sha256
(base32
- "0x62hn8rc7ninf9nlp69h61yh21g4cbq2g81sh64cf2ify2hqk7b"))))
+ "1bciyzwv7gwsnaykqz0czj6mlbkkg4hg1s40s1q7j2p6nlmpxxj5"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-file-which" ,perl-file-which)))
@@ -3559,7 +3559,7 @@ the input record separator string on a per file basis.")
(define-public perl-file-remove
(package
(name "perl-file-remove")
- (version "1.57")
+ (version "1.58")
(source
(origin
(method url-fetch)
@@ -3567,14 +3567,16 @@ the input record separator string on a per file basis.")
"File-Remove-" version ".tar.gz"))
(sha256
(base32
- "1b814lw181kkqh6c1n4p2zlzzsq6ic5pfpr831nphf2w2rhcvgmk"))))
+ "1n6h5w3sp2bs4cfrifdx2z15cfpb4r536179mx1a12xbmj1yrxl1"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
(home-page "https://metacpan.org/release/File-Remove")
(synopsis "Remove files and directories in Perl")
- (description "File::Remove::remove removes files and directories. It acts
-like /bin/rm, for the most part. Although \"unlink\" can be given a list of
-files, it will not remove directories; this module remedies that. It also
-accepts wildcards, * and ?, as arguments for file names.")
+ (description "@code{File::Remove::remove} removes files and directories.
+It acts like @code{/bin/rm}, for the most part. Although @code{unlink} can be
+given a list of files, it will not remove directories; this module remedies
+that. It also accepts wildcards, * and ?, as arguments for file names.")
(license (package-license perl))))
(define-public perl-file-sharedir
@@ -3648,15 +3650,15 @@ allows you to locate these files after installation.")
(define-public perl-file-slurp
(package
(name "perl-file-slurp")
- (version "9999.19")
+ (version "9999.25")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/U/UR/URI/"
+ (uri (string-append "mirror://cpan/authors/id/C/CA/CAPOEIRAB/"
"File-Slurp-" version ".tar.gz"))
(sha256
(base32
- "0hrn4nipwx40d6ji8ssgr5nw986z9iqq8cn0kdpbszh9jplynaff"))))
+ "1hg3bhf5m78d77p4174cnldd75ppyrvr5rkc8w289ihvwsx9gsn7"))))
(build-system perl-build-system)
(home-page "https://metacpan.org/release/File-Slurp")
(synopsis "Reading/Writing/Modifying of complete files")
@@ -3732,14 +3734,14 @@ a safe way.")
(define-public perl-file-which
(package
(name "perl-file-which")
- (version "1.09")
+ (version "1.23")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+ (uri (string-append "mirror://cpan/authors/id/P/PL/PLICEASE/"
"File-Which-" version ".tar.gz"))
(sha256
(base32
- "1hxjyh9yrv32f3g8vrnr8iylzprajsac14vjm75kf1qnj1jyqbxp"))))
+ "0y70qh5kn2hyrrvbsfhg0iws2qggk5vkpz37f7rbd5rd9cjc57dp"))))
(build-system perl-build-system)
(native-inputs `(("test-script" ,perl-test-script)))
(synopsis "Portable implementation of the `which' utility")
@@ -3747,7 +3749,7 @@ a safe way.")
"File::Which was created to be able to get the paths to executable
programs on systems under which the `which' program wasn't implemented in the
shell.")
- (home-page "https://metacpan.org/release/ADAMK/File-Which-1.09")
+ (home-page "https://metacpan.org/release/File-Which")
(license (package-license perl))))
(define-public perl-file-zglob
@@ -4361,15 +4363,15 @@ commands.")
(define-public perl-json
(package
(name "perl-json")
- (version "2.90")
+ (version "4.01")
(source
(origin
(method url-fetch)
- (uri (string-append "mirror://cpan/authors/id/M/MA/MAKAMAKA/"
+ (uri (string-append "mirror://cpan/authors/id/I/IS/ISHIGAKI/"
"JSON-" version ".tar.gz"))
(sha256
(base32
- "127yppvr17qik9pkd1vy901hs4l13kg6rhp76jdgcyask35v7nsd"))))
+ "1vdiw095g5rf51q8d0ipf8020jx371pma0k4sxp0wlfl76lr65b3"))))
(build-system perl-build-system)
(propagated-inputs
`(("perl-json-xs" ,perl-json-xs))) ;recommended
@@ -4436,7 +4438,7 @@ either uses the first module it finds or throws an error.")
(define-public perl-json-xs
(package
(name "perl-json-xs")
- (version "3.01")
+ (version "4.0")
(source
(origin
(method url-fetch)
@@ -4444,8 +4446,10 @@ either uses the first module it finds or throws an error.")
"JSON-XS-" version ".tar.gz"))
(sha256
(base32
- "1aviik480m61ykwvyix83grywzbk828wvfz19hqfvaasd8jz73af"))))
+ "0118yrzagwlcfj5yldn3h23zzqs2rx282jlm068nf7fjlvy4m7s7"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-canary-stability" ,perl-canary-stability)))
(propagated-inputs
`(("perl-common-sense" ,perl-common-sense)
("perl-types-serialiser" ,perl-types-serialiser)))
@@ -5299,7 +5303,7 @@ from Moose::Conflicts and moose-outdated.")
(define-public perl-module-scandeps
(package
(name "perl-module-scandeps")
- (version "1.25")
+ (version "1.27")
(source
(origin
(method url-fetch)
@@ -5307,7 +5311,7 @@ from Moose::Conflicts and moose-outdated.")
"Module-ScanDeps-" version ".tar.gz"))
(sha256
(base32
- "13280nq0d6zc58mcz3kvs2m85a741czq0fabk69ks1nr4j1w2nl4"))))
+ "0j6r9r99x5p0i6fv06i44wpsvjxj32amjkiqf6pmqpj80jff2k7f"))))
(build-system perl-build-system)
(native-inputs
`(("perl-test-requires" ,perl-test-requires)))
@@ -8389,7 +8393,7 @@ algorism to indicate multiplication by 1000.")
(define-public perl-text-template
(package
(name "perl-text-template")
- (version "1.47")
+ (version "1.54")
(source
(origin
(method url-fetch)
@@ -8399,8 +8403,11 @@ algorism to indicate multiplication by 1000.")
".tar.gz"))
(sha256
(base32
- "1z781cgz7wbn80lf3kqr2ad0pg6g1wlnim0822h8liw28k3l5msh"))))
+ "0s56jgak9ccbbbybf5v8hvvhyplbfhzl6p6v1751inly80rlj1kv"))))
(build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-more-utf8" ,perl-test-more-utf8)
+ ("perl-test-warnings" ,perl-test-warnings)))
(home-page
"https://metacpan.org/release/Text-Template")
(synopsis