summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm24
1 files changed, 22 insertions, 2 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 09278f4251..eee688354a 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5746,6 +5746,26 @@ access the DOM object, create and access Javascript, and generate SMIL
animation content.")
(license (package-license perl))))
+(define-public perl-switch
+ (package
+ (name "perl-switch")
+ (version "2.17")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/C/CH/CHORNY/Switch-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0xbdjdgzfj9zwa4j3ipr8bfk7bcici4hk89hq5d27rhg2isljd9i"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Switch")
+ (synopsis "Switch statement for Perl")
+ (description "Switch is a Perl module which implements a generalized case
+mechanism. The module augments the standard Perl syntax with two new
+statements: @code{switch} and @code{case}.")
+ (license (package-license perl))))
+
(define-public perl-sys-cpu
(package
(name "perl-sys-cpu")
@@ -5950,7 +5970,7 @@ done, how much is left to do, and estimate how long it will take.")
(define-public perl-term-readkey
(package
(name "perl-term-readkey")
- (version "2.32")
+ (version "2.37")
(source
(origin
(method url-fetch)
@@ -5958,7 +5978,7 @@ done, how much is left to do, and estimate how long it will take.")
"TermReadKey-" version ".tar.gz"))
(sha256
(base32
- "1y79w5cj98w0a1nqxjhmaw01p2hfhzfw340m2qxd11p6124hxfaq"))))
+ "0hdj5mldpj3pyprd4hbbalfx9yjgi5p59gg2ixk9808f5v7q74sa"))))
(build-system perl-build-system)
(home-page "http://search.cpan.org/dist/TermReadKey")
(synopsis "Simple terminal control")