summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm79
1 files changed, 79 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 52734f5624..4423c77bbd 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -2958,6 +2958,85 @@ either uses the first module it finds or throws an error.")
versa.")
(license (package-license perl))))
+(define-public perl-log-any
+ (package
+ (name "perl-log-any")
+ (version "1.040")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/Log-Any-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0r1q7cclgwl24gzdnjzvd8y0r7j17dngjk492x35w198zhdj2ncp"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Log-Any")
+ (synopsis "Bringing loggers and listeners together")
+ (description "@code{Log::Any} provides a standard log production API for
+modules. @code{Log::Any::Adapter} allows applications to choose the mechanism
+for log consumption, whether screen, file or another logging mechanism like
+@code{Log::Dispatch} or @code{Log::Log4perl}.
+
+A CPAN module uses @code{Log::Any} to get a log producer object. An
+application, in turn, may choose one or more logging mechanisms via
+@code{Log::Any::Adapter}, or none at all.
+
+@code{Log::Any} has a very tiny footprint and no dependencies beyond Perl
+itself, which makes it appropriate for even small CPAN modules to use. It
+defaults to 'null' logging activity, so a module can safely log without
+worrying about whether the application has chosen (or will ever choose) a
+logging mechanism.")
+ (license (package-license perl))))
+
+(define-public perl-log-any-adapter-log4perl
+ (package
+ (name "perl-log-any-adapter-log4perl")
+ (version "0.08")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DA/DAGOLDEN/Log-Any-Adapter-Log4perl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0xf4fnrsznvg0hf36q481124ja1hp3lybki1xjgnk82z9990jmxn"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-log-any" ,perl-log-any)
+ ("perl-log-log4perl" ,perl-log-log4perl)))
+ (home-page
+ "http://search.cpan.org/dist/Log-Any-Adapter-Log4perl")
+ (synopsis "Log::Any adapter for Log::Log4perl")
+ (description "@code{Log::Any::Adapter::Log4perl} provides a
+@code{Log::Any} adapter using @code{Log::Log4perl} for logging.")
+ (license (package-license perl))))
+
+(define-public perl-log-log4perl
+ (package
+ (name "perl-log-log4perl")
+ (version "1.47")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MS/MSCHILLI/Log-Log4perl-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0vxraq9navx5mgf8y8g6l5rbl3dv2ml8bishka5m69hj07nxs0ch"))))
+ (build-system perl-build-system)
+ (home-page
+ "http://search.cpan.org/dist/Log-Log4perl")
+ (synopsis "Log4j implementation for Perl")
+ (description "@code{Log::Log4perl} lets you remote-control and fine-tune
+the logging behaviour of your system from the outside. It implements the
+widely popular (Java-based) Log4j logging package in pure Perl.")
+ (license (package-license perl))))
+
(define-public perl-log-report-optional
(package
(name "perl-log-report-optional")