summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm34
1 files changed, 31 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 81f8f688f6..7beca849c8 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
@@ -2685,6 +2685,34 @@ functionality; it returns a list of file names that match the given pattern.
For instance, it supports the @code{**/*.pm} form.")
(license (package-license perl))))
+(define-public perl-getopt-long
+ (package
+ (name "perl-getopt-long")
+ (version "v2.49.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/J/JV/JV/"
+ "Getopt-Long-" (substring version 1) ".tar.gz"))
+ (sha256
+ (base32
+ "0bw8gbhj8s5gmkqvs3m7pk9arqhgqssrby4yimh29ah9alix9ylq"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Getopt-Long")
+ (synopsis "Module to handle parsing command line options")
+ (description "The @code{Getopt::Long} module implements an extended getopt
+function called @code{GetOptions()}. It parses the command line from
+@code{ARGV}, recognizing and removing specified options and their possible
+values.
+
+This function adheres to the POSIX syntax for command line options, with GNU
+extensions. In general, this means that options have long names instead of
+single letters, and are introduced with a double dash \"--\". Support for
+bundling of command line options, as was the case with the more traditional
+single-letter approach, is provided but not enabled by default.")
+ ;; Can be used with either license.
+ (license (list (package-license perl) gpl2+))))
+
(define-public perl-getopt-long-descriptive
(package
(name "perl-getopt-long-descriptive")
@@ -6053,14 +6081,14 @@ makes fork(2) safe to use in test cases.")
(define-public perl-test-simple
(package
(name "perl-test-simple")
- (version "1.302026")
+ (version "1.302062")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
"Test-Simple-" version ".tar.gz"))
(sha256
(base32
- "1mq1sykv48rgjamw4wxa290mnyjm0dw9w9lpzncnac9gfx18vm72"))))
+ "1sjny65iwnin35lvc203pb07gyx9wrp3gmn6lfrjsbmi986hcab7"))))
(build-system perl-build-system)
(synopsis "Basic utilities for writing tests")
(description