summaryrefslogtreecommitdiff
path: root/gnu/packages/phabricator.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/phabricator.scm')
-rw-r--r--gnu/packages/phabricator.scm66
1 files changed, 15 insertions, 51 deletions
diff --git a/gnu/packages/phabricator.scm b/gnu/packages/phabricator.scm
index e4a4f79942..af95cd93d2 100644
--- a/gnu/packages/phabricator.scm
+++ b/gnu/packages/phabricator.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Robin Templeton <robin@igalia.com>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,48 +25,9 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages))
-(define-public libphutil
- (let ((commit "b29d76e1709ef018cc5edc7c03033fd9fdebc578")
- (revision "1"))
- (package
- (name "libphutil")
- (version (git-version "0.0.0" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/phacility/libphutil")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "06j84721r9r8624fmil62b5crs2qs0v6rr3cvv2zvkvwhxwrwv1l"))))
- (build-system gnu-build-system)
- ;; TODO: Unbundle jsonlint and porter-stemmer.
- (arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda _
- (let ((lib (string-append %output "/lib/libphutil")))
- (mkdir-p lib)
- (copy-recursively "." lib))
- #t)))))
- (inputs
- `(("php" ,php)))
- (home-page "https://github.com/phacility/libphutil")
- (synopsis "PHP utility library")
- (description
- "@code{libphutil} is a collection of utility classes and functions for
-PHP.")
- ;; Bundled libraries are expat-licensed.
- (license (list license:asl2.0 license:expat)))))
-
(define-public arcanist
- (let ((commit "45a8d22c74a62624e69f5cd6ce901c9ab2658904")
- (revision "1"))
+ (let ((commit "ceb082ef6b2919d76a90d4a53ca84f5b1e0c2c06")
+ (revision "2"))
(package
(name "arcanist")
(version (git-version "0.0.0" revision commit))
@@ -77,8 +39,9 @@ PHP.")
(file-name (git-file-name name version))
(sha256
(base32
- "13vswhqy9sap6841y93j4mj71dl27vhcivcn3rzyi0cchkhg2ac9"))))
+ "16590nywh3cpm2yq4igw3nfa8g84kwza215mrnqr2k6b2cqzjak3"))))
(build-system gnu-build-system)
+ ;; TODO: Unbundle jsonlint
(arguments
'(#:tests? #f
#:phases
@@ -86,22 +49,20 @@ PHP.")
(delete 'configure)
(delete 'build)
(replace 'install
- (lambda _
- (let ((bin (string-append %output "/bin"))
- (lib (string-append %output "/lib/arcanist")))
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (lib (string-append out "/lib/arcanist")))
(mkdir-p lib)
(copy-recursively "." lib)
(mkdir-p bin)
(symlink (string-append lib "/bin/arc")
(string-append bin "/arc"))
(wrap-program (string-append bin "/arc")
- `("ARC_PHUTIL_PATH" =
- (,(string-append (assoc-ref %build-inputs "libphutil")
- "/lib/libphutil")))
`("PATH" ":" prefix
(,@(map (lambda (i)
(string-append (assoc-ref %build-inputs i) "/bin"))
- '("git" "mercurial" "subversion"))))))
+ '("php" "git" "mercurial" "subversion"))))))
#t))
(add-before 'reset-gzip-timestamps 'make-compressed-files-writable
(lambda _
@@ -110,7 +71,6 @@ PHP.")
#t)))))
(inputs
`(("php" ,php)
- ("libphutil" ,libphutil)
("git" ,git)
("mercurial" ,mercurial)
("subversion" ,subversion)))
@@ -121,4 +81,8 @@ PHP.")
development service. It allows you to interact with Phabricator installs to
send code for review, download patches, transfer files, view status, make API
calls, and various other things.")
- (license license:asl2.0))))
+ ;; Bundled libraries are expat-licensed.
+ (license (list license:asl2.0 license:expat)))))
+
+(define-public libphutil
+ (deprecated-package "libphutil" arcanist))