summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm166
1 files changed, 83 insertions, 83 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index 80fc963363..c498703205 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -207,23 +207,22 @@ cameras (CRW/CR2, NEF, RAF, DNG, and others).")
;; both two licensing modes for your changes/additions."
(license (list license:lgpl2.1 license:cddl1.0))))
-
(define-public libexif
(package
(name "libexif")
- (version "0.6.22")
+ (version "0.6.24")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libexif/libexif/releases"
- "/download/libexif-"
- (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
- "-release/libexif-" version ".tar.xz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/libexif/libexif.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0mhcad5zab7fsn120rd585h8ncwkq904nzzrq8vcd72hzk4g2j2h"))))
+ "0zi5vvb0khlzc6xyfayk6mjx5lgkrj8r7s8lfv4j7wkcgndjga0j"))))
(build-system gnu-build-system)
- (home-page "https://libexif.github.io/")
+ (native-inputs (list autoconf automake gettext-minimal libtool))
+ (home-page "https://github.com/libexif/libexif")
(synopsis "Read and manipulate EXIF data in digital photographs")
(description
"The libexif C library allows applications to read, edit, and save EXIF
@@ -460,7 +459,7 @@ photographic equipment.")
(define-public darktable
(package
(name "darktable")
- (version "4.2.0")
+ (version "4.2.1")
(source
(origin
(method url-fetch)
@@ -468,101 +467,102 @@ photographic equipment.")
"https://github.com/darktable-org/darktable/releases/"
"download/release-" version "/darktable-" version ".tar.xz"))
(sha256
- (base32 "1y8sn7yyqyg1n82byaw5csjr8a6m7g6839krq9k9zc79vxzr3c0q"))))
+ (base32 "1b3vr6njwqfvnrx3qpbg5aqcbl1z8nxnxcgyyw0sd4a20z33jfk0"))))
(build-system cmake-build-system)
(arguments
- `(#:configure-flags '("-DBINARY_PACKAGE_BUILD=On"
- "-DBUILD_TESTING=On")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'libOpenCL-path
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Statically link to libOpenCL.
- (substitute* "./src/common/dlopencl.c"
- (("\"libOpenCL\"")
- (string-append "\"" (assoc-ref inputs "opencl-icd-loader")
- "/lib/libOpenCL.so\"")))))
- (add-after 'unpack 'fix-missing-include
- (lambda _
- ;; Fix missing include needed to build tests. See upstream
- ;; issue: https://github.com/darktable-org/darktable/issues/12604
- (substitute* "./src/common/variables.h"
- (("once")
- "once\n#include \"common/image.h\""))))
- (add-before 'configure 'prepare-build-environment
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Rawspeed fails to build with GCC due to OpenMP error:
- ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
- (setenv "CC" "clang") (setenv "CXX" "clang++")
- ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
- ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
- (substitute* "CMakeLists.txt"
- (("\\$\\{LLVM_INSTALL_PREFIX\\}")
- (assoc-ref %build-inputs "clang")))))
- (add-before 'configure 'set-LDFLAGS
- (lambda* (#:key outputs #:allow-other-keys)
- (setenv "LDFLAGS"
- (string-append
- "-Wl,-rpath="
- (assoc-ref outputs "out") "/lib/darktable"))))
- (add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (wrap-program (string-append (assoc-ref outputs "out")
- "/bin/darktable")
- ;; For GtkFileChooserDialog.
- `("GSETTINGS_SCHEMA_DIR" =
- (,(string-append (assoc-ref inputs "gtk+")
- "/share/glib-2.0/schemas")))))))))
+ (list
+ #:configure-flags
+ #~(list "-DBINARY_PACKAGE_BUILD=On"
+ "-DBUILD_TESTING=On")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'libOpenCL-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Statically link to libOpenCL.
+ (substitute* "./src/common/dlopencl.c"
+ (("\"libOpenCL\"")
+ (string-append "\""
+ (search-input-file inputs "/lib/libOpenCL.so")
+ "\"")))))
+ (add-after 'unpack 'fix-missing-include
+ (lambda _
+ ;; Fix missing include needed to build tests. See upstream
+ ;; issue: https://github.com/darktable-org/darktable/issues/12604
+ (substitute* "./src/common/variables.h"
+ (("once")
+ "once\n#include \"common/image.h\""))))
+ (add-before 'configure 'prepare-build-environment
+ (lambda _
+ ;; Rawspeed fails to build with GCC due to OpenMP error:
+ ;; "undefined reference to `GOMP_loop_nonmonotonic_dynamic_next'"
+ (setenv "CC" "clang")
+ (setenv "CXX" "clang++")
+ ;; Darktable looks for opencl-c.h in the LLVM dir. Guix installs
+ ;; it to the Clang dir. We fix this by patching CMakeLists.txt.
+ (substitute* "CMakeLists.txt"
+ (("\\$\\{LLVM_INSTALL_PREFIX\\}")
+ #$(this-package-native-input "clang")))))
+ (add-before 'configure 'set-LDFLAGS
+ (lambda _
+ (setenv "LDFLAGS"
+ (string-append "-Wl,-rpath=" #$output "/lib/darktable"))))
+ (add-after 'install 'wrap-program
+ (lambda _
+ (wrap-program (string-append #$output "/bin/darktable")
+ ;; For GtkFileChooserDialog.
+ `("GSETTINGS_SCHEMA_DIR" =
+ (,(string-append #$(this-package-input "gtk+")
+ "/share/glib-2.0/schemas")))))))))
(native-inputs
- `(("clang" ,clang-11)
- ("cmocka" ,cmocka)
- ("desktop-file-utils" ,desktop-file-utils)
- ("glib:bin" ,glib "bin")
- ("gobject-introspection" ,gobject-introspection)
- ("intltool" ,intltool)
- ("llvm" ,llvm-11) ;should match the Clang version
- ("opencl-headers" ,opencl-headers)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("po4a" ,po4a)
- ("python-wrapper" ,python-wrapper)
- ("ruby" ,ruby)))
+ (list clang-11
+ cmocka
+ desktop-file-utils
+ `(,glib "bin")
+ gobject-introspection
+ intltool
+ llvm-11 ;should match the Clang version
+ opencl-headers
+ perl
+ pkg-config
+ po4a
+ python-wrapper
+ ruby))
(inputs
(list bash-minimal
cairo
- colord-gtk ;optional, for color profile support
- cups ;optional, for printing support
+ colord-gtk ;optional, for color profile support
+ cups ;optional, for printing support
curl
dbus-glib
exiv2
freeimage
- gmic ;optional, for HaldcLUT support
+ gmic ;optional, for HaldcLUT support
graphicsmagick
gsettings-desktop-schemas
gtk+
imath
- iso-codes ;optional, for language names in the preferences
+ iso-codes ;optional, for language names in the preferences
json-glib
lcms
- lensfun ;optional, for the lens distortion plugin
- libgphoto2 ;optional, for camera tethering
- libavif ;optional, for AVIF support
+ lensfun ;optional, for the lens distortion plugin
+ libgphoto2 ;optional, for camera tethering
+ libavif ;optional, for AVIF support
libjpeg-turbo
libomp
libpng
librsvg
- libsecret ;optional, for storing passwords
+ libsecret ;optional, for storing passwords
libsoup-minimal-2
libtiff
- libwebp ;optional, for WebP support
+ libwebp ;optional, for WebP support
libxml2
libxslt
libheif
- lua-5.4 ;optional, for plugins
- opencl-icd-loader ;optional, for OpenCL support
- openexr ;optional, for EXR import/export
- openjpeg ;optional, for JPEG2000 export
- osm-gps-map ;optional, for geotagging view
+ lua-5.4 ;optional, for plugins
+ opencl-icd-loader ;optional, for OpenCL support
+ openexr ;optional, for EXR import/export
+ openjpeg ;optional, for JPEG2000 export
+ osm-gps-map ;optional, for geotagging view
pugixml
python-jsonschema
sdl2
@@ -577,8 +577,8 @@ and enhance them.")
(supported-systems '("x86_64-linux" "aarch64-linux" "powerpc64le-linux"))
(properties
'((release-monitoring-url . "https://github.com/darktable-org/darktable/releases")))
- (license (list license:gpl3+ ;; Darktable itself.
- license:lgpl2.1+)))) ;; Rawspeed library.
+ (license (list license:gpl3+ ;Darktable itself
+ license:lgpl2.1+)))) ;Rawspeed library
(define-public photoflare
(package