summaryrefslogtreecommitdiff
path: root/gnu/packages/photo.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/photo.scm')
-rw-r--r--gnu/packages/photo.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/photo.scm b/gnu/packages/photo.scm
index f5e43af4f4..c1b196f438 100644
--- a/gnu/packages/photo.scm
+++ b/gnu/packages/photo.scm
@@ -152,13 +152,14 @@ from digital cameras.")
("libexif" ,libexif)
("libgphoto2" ,libgphoto2)))
(arguments
- '(#:phases (alist-cons-before
- 'check 'pre-check
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "tests/data" "\\.param$")
- (("/usr/bin/env")
- (which "env"))))
- %standard-phases)
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'pre-check
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "tests/data" "\\.param$")
+ (("/usr/bin/env")
+ (which "env")))
+ #t)))
;; FIXME: There are 2 test failures, most likely related to the build
;; environment.