summaryrefslogtreecommitdiff
path: root/gnu/packages/plotutils.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/plotutils.scm')
-rw-r--r--gnu/packages/plotutils.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/plotutils.scm b/gnu/packages/plotutils.scm
index 4b89ddafd1..cb6ac63005 100644
--- a/gnu/packages/plotutils.scm
+++ b/gnu/packages/plotutils.scm
@@ -224,13 +224,13 @@ colors, styles, options and details.")
("perl" ,perl)
("texinfo" ,texinfo) ;For generating documentation
;; For the manual and the tests.
- ("texlive" ,(texlive-union (list texlive-amsfonts/patched
+ ("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-epsf
texlive-etoolbox
texlive-latex-base
texlive-latex-geometry
texlive-latex-graphics
- texlive-latex-oberdiek ; for ifluatex
+ texlive-oberdiek ;for ifluatex
texlive-latex-parskip
texlive-tex-texinfo)))))
(inputs
@@ -306,9 +306,9 @@ colors, styles, options and details.")
(lambda* (#:key inputs outputs #:allow-other-keys)
;; Make sure 'xasy' runs with the correct PYTHONPATH.
(let* ((out (assoc-ref outputs "out"))
- (path (getenv "PYTHONPATH")))
+ (path (getenv "GUIX_PYTHONPATH")))
(wrap-program (string-append out "/share/asymptote/GUI/xasy.py")
- `("PYTHONPATH" ":" prefix (,path))))
+ `("GUIX_PYTHONPATH" ":" prefix (,path))))
#t)))))
(home-page "http://asymptote.sourceforge.net")
(synopsis "Script-based vector graphics language")