summaryrefslogtreecommitdiff
path: root/gnu/packages/prolog.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/prolog.scm')
-rw-r--r--gnu/packages/prolog.scm43
1 files changed, 0 insertions, 43 deletions
diff --git a/gnu/packages/prolog.scm b/gnu/packages/prolog.scm
index 20e6119731..7c344988d5 100644
--- a/gnu/packages/prolog.scm
+++ b/gnu/packages/prolog.scm
@@ -67,46 +67,3 @@ manner. It also features an interactive interpreter.")
(supported-systems (fold delete
%supported-systems
'("armhf-linux" "mips64el-linux")))))
-
-;; TODO: This current version of SWI-PROLOG using the
-;; tarball from the official website is completely self-contained
-;; such that all submodules are provided. Eventually replace this
-;; and manually patch those submodules.
-(define-public swi-prolog
- (package
- (name "swi-prolog")
- (version "8.0.3")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://www.swi-prolog.org/download/stable/src/swipl-"
- version ".tar.gz"))
- (sha256
- (base32
- "1bnnwbdxnifb1qj42prsqhx8y0k2z596wgvh4bbnd0bw8w59rrff"))))
- (build-system cmake-build-system)
- (arguments
- `(#:parallel-build? #f
- #:tests? #t)) ; FIXME:
- ;#:configure-flags
- ; (list "-DINSTALL_DOCUMENTATION=OFF"))) ; FIXME:
- (native-inputs
- `(("zlib" ,zlib)
- ("gmp" ,gmp)
- ("readline" ,readline)
- ;("texlive" ,texlive)
- ("texinfo" ,texinfo)
- ("libunwind" ,libunwind)
- ("libjpeg", libjpeg)
- ("libxft" ,libxft)
- ("fontconfig" ,fontconfig)
- ("perl" ,perl)
- ("pkg-config" ,pkg-config)
- ("openssl" ,openssl)))
- (home-page "https://www.swi-prolog.org/")
- (synopsis "ISO/Edinburgh-style Prolog interpreter")
- (description "SWI-Prolog is a fast and powerful ISO/Edinburgh-style Prolog
-compiler with a rich set of built-in predicates. It offers a fast, robust and
-small environment which enables substantial applications to be developed with
-it.")
- (license #f))) ; TODO: