summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index f971dae5b4..5bbe544113 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1494,7 +1494,7 @@ libraries.")
(setenv "QT_QPA_PLATFORM" "offscreen")
#t)))))
(propagated-inputs
- (list python-pyqt))
+ (list python-pyqt-without-qtwebkit))
(native-inputs
(list python-pytest python-pytest-runner python-setuptools-scm))
(home-page "https://github.com/pytest-dev/pytest-qt")
@@ -1658,7 +1658,9 @@ supported by the MyPy typechecker.")
(file-name (git-file-name name version))
(sha256
(base32
- "1v83flrdxh8grcp40qw04q4hzjflih9xwib64078vsxv2w36f817"))))
+ "1v83flrdxh8grcp40qw04q4hzjflih9xwib64078vsxv2w36f817"))
+ (patches
+ (search-patches "python-mypy-12332.patch"))))
(build-system python-build-system)
(arguments
`(#:phases