summaryrefslogtreecommitdiff
path: root/gnu/packages/python-check.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-check.scm')
-rw-r--r--gnu/packages/python-check.scm60
1 files changed, 60 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 9849b16685..f98a6bb37b 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2020 Edouard Klein <edk@beaver-labs.com>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
+;;; Copyright © 2021 Sharlatan Hellseher <sharlatanus@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -196,6 +197,65 @@ interactions, which will update them to correspond to the new API.")
of tests run in a specific order.")
(license license:expat)))
+(define-public python-pytest-astropy-header
+(package
+ (name "python-pytest-astropy-header")
+ (version "0.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-astropy-header" version))
+ (sha256
+ (base32 "1y87agr324p6x5gvhziymxjlw54pyn4gqnd49papbl941djpkp5g"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("pytest" ,python-pytest)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://www.astropy.org/")
+ (synopsis
+ "Pytest plugin adding diagnostic data to the header of the test output")
+ (description
+ "This plugin package provides a way to include information about the system,
+Python installation, and select dependencies in the header of the output when
+running pytest. It can be used with packages that are not affiliated with the
+Astropy project, but is optimized for use with astropy-related projects.")
+ (license license:bsd-3)))
+
+(define-public python-pytest-astropy
+ (package
+ (name "python-pytest-astropy")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pytest-astropy" version))
+ (sha256
+ (base32 "18j6z6y2fvykmcs5z0mldhhaxxn6wzpnhlm2ps7m8r5z5kmh1631"))))
+ (build-system python-build-system)
+ (arguments
+ ;; No tests provided
+ '(#:tests? #f))
+ (native-inputs
+ `(("attrs" ,python-attrs)
+ ("hypothesis" ,python-hypothesis)
+ ("pytest" ,python-pytest)
+ ("pytest-arraydiff" ,python-pytest-arraydiff)
+ ("pytest-astropy-header" ,python-pytest-astropy-header)
+ ("pytest-cov" ,python-pytest-cov)
+ ("pytest-doctestplus" ,python-pytest-doctestplus)
+ ("pytest-filter-subpackage" ,python-pytest-filter-subpackage)
+ ("pytest-mock" ,python-pytest-mock)
+ ("pytest-openfiles" ,python-pytest-openfiles)
+ ("pytest-remotedata" ,python-pytest-remotedata)
+ ("setuptools-scm" ,python-setuptools-scm)))
+ (home-page "https://github.com/astropy/pytest-astropy")
+ (synopsis
+ "Metapackage for all the testing machinery used by the Astropy Project")
+ (description
+ "This is a meta-package that pulls in the dependencies that are used by
+astropy related packages.")
+ (license license:bsd-3)))
+
(define-public python-pytest-arraydiff
(package
(name "python-pytest-arraydiff")