summaryrefslogtreecommitdiff
path: root/gnu/packages/python-crypto.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-crypto.scm')
-rw-r--r--gnu/packages/python-crypto.scm61
1 files changed, 1 insertions, 60 deletions
diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index bf083497d0..3e7704bf48 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -76,30 +76,6 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (srfi srfi-1))
-(define-public python-potr
- (package
- (name "python-potr")
- (version "1.0.2")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/python-otr/pure-python-otr")
- (commit version)))
- (file-name
- (git-file-name name version))
- (sha256
- (base32 "1hzw6h01fm216nmipyylgz0zybd80w1xsk12m7djycnhqrnrvvv1"))))
- (build-system python-build-system)
- (propagated-inputs
- (list python-pycrypto))
- (synopsis "Python OTR Implementation")
- (description "Python OTR is an Off-The-Record Protocol Implementation in
-Python. It does not bind to libotr.")
- (home-page "https://github.com/python-otr/pure-python-otr")
- (license license:lgpl3+)))
-
(define-public python-base58
(package
(name "python-base58")
@@ -265,41 +241,6 @@ messages, and verify the signatures. The keys and signatures are very short,
making them easy to handle and incorporate into other protocols.")
(license license:expat)))
-;;; Pycrypto is abandoned upstream:
-;;;
-;;; https://github.com/dlitz/pycrypto/issues/173
-;;;
-;;; TODO Remove this package from GNU Guix.
-(define-public python-pycrypto
- (package
- (name "python-pycrypto")
- (version "2.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pycrypto" version))
- (patches (search-patches "python-pycrypto-CVE-2013-7459.patch"
- "python-pycrypto-time-clock.patch"))
- (sha256
- (base32
- "0g0ayql5b9mkjam8hym6zyg6bv77lbh66rv1fyvgqb17kfc1xkpj"))))
- (build-system python-build-system)
- (inputs
- (list python gmp))
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-build-env
- ;; pycrypto runs an autoconf configure script behind the scenes
- (lambda _ (setenv "CONFIG_SHELL" (which "bash")) #t)))))
- (home-page "https://www.dlitz.net/software/pycrypto/")
- (synopsis "Cryptographic modules for Python")
- (description
- "Pycrypto is a collection of both secure hash functions (such as SHA256
-and RIPEMD160), and various encryption algorithms (AES, DES, RSA, ElGamal,
-etc.). The package is structured to make adding new modules easy.")
- (license license:public-domain)))
-
(define-public python-kerberos
(package
(name "python-kerberos")
@@ -580,7 +521,7 @@ is used by the Requests library to verify HTTPS requests.")
python-hypothesis
python-iso8601
python-pretend
- python-pytest-7.1 ;for subtests
+ python-pytest ;for subtests
python-pytest-benchmark
python-pytest-subtests))
(inputs (list python-cryptography-rust))