summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 8ebae2e4b7..4868baa928 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2017 Mark Meyer <mark@ofosos.org>
;;; Copyright © 2018 Tomáš Čech <sleep_walker@gnu.org>
;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2018 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2090,6 +2091,9 @@ users' sessions over extended periods of time.")
library for Python")
(license license:asl2.0)))
+(define-public python2-oauth2client
+ (package-with-python2 python-oauth2client))
+
(define-public python-flask-oidc
(package
(name "python-flask-oidc")
@@ -2620,3 +2624,30 @@ name resolutions asynchronously.")
(description "@code{yarl} module provides handy @code{URL} class
for URL parsing and changing.")
(license license:asl2.0)))
+
+(define-public python-google-api-client
+ (package
+ (name "python-google-api-client")
+ (version "1.6.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "google-api-python-client" version))
+ (sha256
+ (base32
+ "1wpbbbxfpy9mwxdy3kn352cb590ladv574j1aa2l4grjdqw3ln05"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f)) ; tests require internet access
+ (native-inputs
+ `(("python-httplib2" ,python-httplib2)
+ ("python-six" ,python-six)
+ ("python-oauth2client" ,python-oauth2client)
+ ("python-uritemplate" ,python-uritemplate)))
+ (home-page "https://github.com/google/google-api-python-client")
+ (synopsis "Core Python library for accessing Google APIs")
+ (description "Python client library for Google's discovery based APIs")
+ (license license:asl2.0)))
+
+(define-public python2-google-api-client
+ (package-with-python2 python-google-api-client))