summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 6aaa7504c4..9939a994b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5311,15 +5311,24 @@ ecosystem.")
(define-public python-hyperlink
(package
(name "python-hyperlink")
- (version "19.0.0")
+ (version "21.0.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "hyperlink" version))
(sha256
(base32
- "0m2nhi0j8wmgfscf974wd5v1xfq8mah286hil6npy1ys0m3y7222"))))
- (build-system python-build-system)
+ "0sx50lkivsfjxx9zr4yh7l9gll2l9kvl0v0w8w4wk2x5v9bzjyj2"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'pretend-to-be-CI
+ (lambda _
+ ;; Pretend to be a CI system to skip flaky tests.
+ (setenv "CI" "true"))))))
+ (native-inputs
+ (list python-pytest))
(propagated-inputs
(list python-idna))
(home-page "https://github.com/python-hyper/hyperlink")