summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 12 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1758450c2f..e3d1ac05fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -439,7 +439,7 @@ easy logging and rotating to a console or a file.")
(invoke "pytest" "--cov=logbook" "-r" "s" "tests")))))))
(native-inputs
(list python-cython python-mock python-pytest python-pytest-cov
- python-google-brotli))
+ python-brotli))
(home-page "https://github.com/getlogbook/logbook")
(synopsis "Logbook is a logging replacement for Python")
(description
@@ -11284,14 +11284,22 @@ Python.")
(package
(inherit python-mistune)
(name "python-mistune-next")
- (version "2.0.0rc1")
+ (version "2.0.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "mistune" version))
(sha256
(base32
- "1nd7iav1ixh9hlj4hxn6lmpava88d86ys8rqm30wgvr7gjlxnas5"))))
- (native-inputs (list python-nose))))
+ "024q9l6mgd37wa25w7dhskv1m3zsj5lf0w9cfyx7l9p2adhadq4y"))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-vv")))))))
+ (native-inputs (list python-pytest))))
(define-public python-markdown
(package