summaryrefslogtreecommitdiff
path: root/gnu/packages/python-xyz.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python-xyz.scm')
-rw-r--r--gnu/packages/python-xyz.scm61
1 files changed, 46 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5591210fce..ba6f2cbcbb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5900,7 +5900,7 @@ readable format.")
texlive-capt-of
texlive-cm-super
texlive-fonts-ec
- texlive-generic-iftex
+ texlive-iftex
texlive-pdftex
texlive-amsfonts
texlive-latex-cmap
@@ -5908,13 +5908,13 @@ readable format.")
texlive-latex-eqparbox
texlive-etoolbox
texlive-latex-expdlist
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
+ texlive-fancyhdr
+ texlive-fancyvrb
texlive-latex-fncychap
texlive-latex-float
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-graphics
+ texlive-graphics
texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
@@ -5924,7 +5924,7 @@ readable format.")
texlive-latex-preview
texlive-latex-tabulary
texlive-latex-threeparttable
- texlive-latex-titlesec
+ texlive-titlesec
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
@@ -8998,20 +8998,20 @@ computing.")
("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-capt-of
texlive-fonts-ec
- texlive-generic-iftex
+ texlive-iftex
texlive-pdftex
texlive-latex-cmap
texlive-latex-environ
texlive-latex-eqparbox
texlive-etoolbox
texlive-latex-expdlist
- texlive-latex-fancyhdr
- texlive-latex-fancyvrb
+ texlive-fancyhdr
+ texlive-fancyvrb
texlive-latex-fncychap
texlive-latex-float
texlive-latex-framed
texlive-latex-geometry
- texlive-latex-graphics
+ texlive-graphics
texlive-hyperref
texlive-latex-mdwtools
texlive-latex-multirow
@@ -9021,7 +9021,7 @@ computing.")
texlive-latex-preview
texlive-latex-tabulary
texlive-latex-threeparttable
- texlive-latex-titlesec
+ texlive-titlesec
texlive-latex-trimspaces
texlive-latex-ucs
texlive-latex-upquote
@@ -12798,7 +12798,40 @@ time.")
;;("python-pyppeteer" ,python-pyppeteer)
("python-pytest" ,python-pytest)
("python-pytest-cov" ,python-pytest-cov)
- ("python-pytest-dependency" ,python-pytest-dependency)))
+ ("python-pytest-dependency" ,python-pytest-dependency)
+ ("texlive" ,(texlive-updmap.cfg
+ (list texlive-adjustbox
+ texlive-amsfonts
+ texlive-booktabs
+ texlive-caption
+ texlive-eurosym
+ texlive-fancyvrb
+ texlive-fonts-rsfs
+ texlive-fontspec
+ texlive-generic-ulem
+ texlive-grffile
+ texlive-hyperref
+ texlive-iftex
+ texlive-jknappen
+ texlive-latex-amsmath
+ texlive-latex-enumitem
+ texlive-latex-float
+ texlive-latex-geometry
+ texlive-latex-jknapltx
+ texlive-latex-parskip
+ texlive-latex-trimspaces
+ texlive-latex-ucs
+ texlive-latex-upquote
+ texlive-lm
+ texlive-mathpazo
+ texlive-ms
+ texlive-oberdiek
+ texlive-stringenc
+ texlive-tcolorbox
+ texlive-titling
+ texlive-tools
+ texlive-xcolor
+ texlive-zapfding)))))
(propagated-inputs
(list python-bleach
python-defusedxml
@@ -15549,9 +15582,7 @@ syntax highlighting, markdown and more to the terminal.")
(list which))
(inputs
;; python-magic needs to be able to find libmagic.so.
- ;; Use a newer version because 5.39 returns bogus for some archives
- ;; (notably Chromium .crx extensions), which breaks e.g. 'diffoscope'.
- (list file-next))
+ (list file))
(synopsis "File type identification using libmagic")
(description
"This module uses ctypes to access the libmagic file type
@@ -26766,7 +26797,7 @@ By default it uses the open Python vulnerability database Safety DB.")
(native-inputs
`(("texlive" ,(texlive-updmap.cfg (list texlive-amsfonts
texlive-fonts-ec
- texlive-generic-iftex
+ texlive-iftex
texlive-hyperref
texlive-oberdiek
texlive-lm