summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ea94f44230..8f8b0de721 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3261,11 +3261,12 @@ association studies (GWAS) on extremely large data sets.")
(name "python-numpy")
(outputs '("out" "doc"))
(inputs
- `(("which" ,which)))
+ `(("which" ,which)
+ ,@(package-inputs python-numpy-bootstrap)))
(propagated-inputs
`(("python-matplotlib" ,python-matplotlib)
("python-pyparsing" ,python-pyparsing)
- ,@(package-inputs python-numpy-bootstrap)))
+ ,@(package-propagated-inputs python-numpy-bootstrap)))
(native-inputs
`(("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)
@@ -3390,7 +3391,7 @@ that client code uses to construct the grammar directly in Python code.")
(substitute* "numpydoc/tests/test_plot_directive.py"
(("3") "2"))))))
(build-system python-build-system)
- (native-inputs
+ (propagated-inputs
`(("python-sphinx" ,python-sphinx)))
(native-inputs
`(("python-nose" ,python-nose)))
@@ -4814,7 +4815,7 @@ computing.")
;; FIXME: add pyreadline once available.
(native-inputs
`(("python2-mock" ,python2-mock)
- ,@(package-inputs ipython))))))
+ ,@(package-native-inputs ipython))))))
(define-public python-isodate
(package
@@ -6371,14 +6372,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography-vectors
(package
(name "python-cryptography-vectors")
- (version "1.5.3")
+ (version "1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography_vectors" version))
(sha256
(base32
- "1bnd1bricyhxa27rhr0ljk0kacxzvysd3ar2j2hlv13a2k6zw4z5"))))
+ "0xgn3yvlmv5rs92wgjj39qscr6s7mwbbsx7j683sfa6ijmyb1k01"))))
(build-system python-build-system)
(home-page "https://github.com/pyca/cryptography")
(synopsis "Test vectors for the cryptography package")
@@ -6393,14 +6394,14 @@ responses, rather than doing any computation.")
(define-public python-cryptography
(package
(name "python-cryptography")
- (version "1.5.3")
+ (version "1.6")
(source
(origin
(method url-fetch)
(uri (pypi-uri "cryptography" version))
(sha256
(base32
- "1raanvkdfw5ai56ymlij6ghc4k126fs7jx948ig7yn4vj6ndv0ng"))))
+ "0gwvmz6w5ml0bjbgmdiscsv5i948lrjd381z7h9qkz6kr398c3ad"))))
(build-system python-build-system)
(arguments
`(#:phases