summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d4e01202b5..b05911db56 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10446,7 +10446,12 @@ possible on all supported Python versions.")
(license license:expat)))
(define-public python2-xopen
- (package-with-python2 python-xopen))
+ (let ((base (package-with-python2
+ (strip-python2-variant python-xopen))))
+ (package
+ (inherit base)
+ (propagated-inputs `(("python2-bz2file" ,python2-bz2file)
+ ,@(package-propagated-inputs base))))))
(define-public python2-cheetah
(package