summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm14
1 files changed, 3 insertions, 11 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 05d3390604..76b5460f63 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5488,7 +5488,7 @@ complexity of Python source code.")
(package (inherit base)
(propagated-inputs
`(("python2-configparser" ,python2-configparser)
- ("python2-enum" ,python2-enum)
+ ("python2-enum34" ,python2-enum34)
,@(package-propagated-inputs base))))))
;; python-hacking requires flake8 <2.6.0.
@@ -12101,18 +12101,10 @@ ignoring formatting changes.")
"Make loops show a progress bar on the console by just wrapping any
iterable with @code{|tqdm(iterable)|}. Offers many options to define
design and layout.")
- (license (list license:mpl2.0 license:expat))
- (properties `((python2-variant . ,(delay python2-tqdm))))))
+ (license (list license:mpl2.0 license:expat))))
(define-public python2-tqdm
- (let ((tqdm (package-with-python2
- (strip-python2-variant python-tqdm))))
- (package
- (inherit tqdm)
- (native-inputs
- ;; FIXME: This should be propagated from python2-flake8 instead.
- `(("python2-enum34" ,python2-enum34)
- ,@(package-native-inputs tqdm))))))
+ (package-with-python2 python-tqdm))
(define-public python-pkginfo
(package