summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm10
1 files changed, 7 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 29371d0494..8261fefd93 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1699,7 +1699,7 @@ software.")
(define-public python-mimeparse
(package
(name "python-mimeparse")
- (version "0.1.4")
+ (version "1.6.0")
(source
(origin
(method url-fetch)
@@ -1708,10 +1708,14 @@ software.")
version ".tar.gz"))
(sha256
(base32
- "1hyxg09kaj02ri0rmwjqi86wk4nd1akvv7n0dx77azz76wga4s9w"))))
+ "0y2g6cl660bpz11srgqyvvm8gmywpgyx8g0xfvbiyr0af0yv1r3n"))))
(build-system python-build-system)
(arguments
- '(#:tests? #f)) ; no setup.py test command
+ '(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "./mimeparse_test.py"))))))
(home-page
"https://github.com/dbtsai/python-mimeparse")
(synopsis "Python library for parsing MIME types")