summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm19
1 files changed, 5 insertions, 14 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 730faf4557..39d8931c13 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1765,7 +1765,7 @@ matching them against a list of media-ranges.")
;; Expected '/tmp/guix-build-python-py-1.4.31.drv-0/py-1.4.31/py'.
;; Is this module globally installed?"
'(#:tests? #f))
- (home-page "http://pylib.readthedocs.io/")
+ (home-page "https://pylib.readthedocs.io/")
(synopsis "Python library for parsing, I/O, instrospection, and logging")
(description
"Py is a Python library for file name parsing, .ini file parsing, I/O,
@@ -3669,14 +3669,14 @@ operators such as union, intersection, and difference.")
(define-public python-rpy2
(package
(name "python-rpy2")
- (version "2.9.0")
+ (version "2.9.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rpy2" version))
(sha256
(base32
- "0bqihjrdqwj5r1h86shvfb1p5hfr4a6klv1v54bzfr9r144w3rni"))))
+ "0bl1d2qhavmlrvalir9hmkjh74w21vzkvc2sg3cbb162s10zfmxy"))))
(build-system python-build-system)
(arguments
'(#:modules ((ice-9 ftw)
@@ -3686,14 +3686,6 @@ operators such as union, intersection, and difference.")
(guix build python-build-system))
#:phases
(modify-phases %standard-phases
- ;; Without this phase the test loader cannot find the directories, in
- ;; which it is supposed to look for test files.
- (add-after 'unpack 'fix-tests
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "rpy/tests.py"
- (("loader.discover\\(")
- "loader.discover(rpy_root + '/' +"))
- #t))
(replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(let ((cwd (getcwd)))
@@ -3703,8 +3695,7 @@ operators such as union, intersection, and difference.")
(scandir (string-append cwd "/build")))
":"
(getenv "PYTHONPATH"))))
- ;; FIXME: Even when all tests pass, the check phase will fail.
- (system* "python" "-m" "rpy2.tests" "-v"))))))
+ (invoke "python" "-m" "rpy2.tests" "-v"))))))
(propagated-inputs
`(("python-six" ,python-six)
("python-jinja2" ,python-jinja2)
@@ -3722,7 +3713,7 @@ operators such as union, intersection, and difference.")
("python-numpy" ,python-numpy)))
(native-inputs
`(("zlib" ,zlib)))
- (home-page "http://rpy.sourceforge.net/")
+ (home-page "https://rpy2.bitbucket.io/")
(synopsis "Python interface to the R language")
(description "rpy2 is a redesign and rewrite of rpy. It is providing a
low-level interface to R from Python, a proposed high-level interface,