summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm71
1 files changed, 67 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a8ba1b8c76..5631c7ac0b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -829,14 +829,14 @@ concepts.")
(define-public python-netcdf4
(package
(name "python-netcdf4")
- (version "1.2.6")
+ (version "1.2.7")
(source
(origin
(method url-fetch)
(uri (pypi-uri "netCDF4" version))
(sha256
(base32
- "1qcymsfxsdfr4sx0vl7ih5d14z66k6c9sjy4gb6rjaksk5387zvg"))))
+ "1fllizmnpw0zkzzm4j9pgamarlzfn3kmv9zrm0w65q1y31h9ni0c"))))
(build-system python-build-system)
(native-inputs
`(("python-cython" ,python-cython)))
@@ -1020,6 +1020,40 @@ etc.). The package is structured to make adding new modules easy.")
"python"
(package-inputs pycrypto)))))))
+(define-public python-eventlet
+ (package
+ (name "python-eventlet")
+ (version "0.20.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "eventlet" version))
+ (sha256
+ (base32
+ "0f3q55mq4n021wb7qa53pz3ix6i2py64sap66vsaqm2scjw83m9s"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-greenlet" ,python-greenlet)))
+ (home-page "http://eventlet.net")
+ (synopsis "Concurrent networking library for Python")
+ (description
+ "Eventlet is a concurrent networking library for Python that
+allows you to change how you run your code, not how you write it.
+It uses @code{epoll} or @code{libevent} for highly scalable non-blocking I/O.
+Coroutines ensure that the developer uses a blocking style of programming
+that is similar to threading, but provide the benefits of non-blocking I/O.
+The event dispatch is implicit, which means you can easily use @code{Eventlet}
+from the Python interpreter, or as a small part of a larger application.")
+ (license license:expat)))
+
+(define-public python2-eventlet
+ (let ((base (package-with-python2
+ (strip-python2-variant python-eventlet))))
+ (package (inherit base)
+ (propagated-inputs
+ `(("python2-enum34" ,python2-enum34)
+ ,@(package-propagated-inputs base))))))
+
(define-public python-keyring
(package
(name "python-keyring")
@@ -2499,13 +2533,13 @@ installed with a newer @code{pip} or with wheel's own command line utility.")
(define-public python-requests
(package
(name "python-requests")
- (version "2.12.4")
+ (version "2.13.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests" version))
(sha256
(base32
- "0d5fwxmw4ibynk3imph3n4n84m0n3ib1vj339fxhkqri0qd4767d"))))
+ "1s0wg4any4dsv5l3hqjxqk2zgb7pdbqhy9rhc8kh3aigfq4ws8jp"))))
;; TODO: unbundle urllib3 and chardet.
(build-system python-build-system)
(arguments
@@ -2670,6 +2704,35 @@ somewhat intelligeble.")
(define-public python2-pyjwt
(package-with-python2 python-pyjwt))
+(define-public python-pykka
+ (package
+ (name "python-pykka")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "Pykka" version))
+ (sha256
+ (base32
+ "049w3r0mdnnw7xv19jiq7rvls9k7xs73x05b4qs5d6z4vvmgyiz8"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)
+ ("python-gevent" ,python-gevent)
+ ("python-eventlet" ,python-eventlet)))
+ (home-page "https://www.pykka.org/")
+ (synopsis "Pykka is a Python implementation of the actor model")
+ (description
+ "Pykka is a Python implementation of the actor model.
+The actor model introduces some simple rules to control the sharing
+of state and cooperation between execution units, which makes it
+easier to build concurrent applications.")
+ (license license:asl2.0)))
+
+(define-public python2-pykka
+ (package-with-python2 python-pykka))
+
(define-public python-oauthlib
(package
(name "python-oauthlib")