summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm63
1 files changed, 62 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 5a1d3f22c8..4937addf1e 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2020 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
-;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2021, 2022 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 Nicolò Balzarotti <nicolo@nixo.xyz>
;;; Copyright © 2022 Foo Chuan Wei <chuanwei.foo@hotmail.com>
@@ -4056,3 +4056,64 @@ data.")
also compatible with SGI and TGS Open Inventor, and the API is based on the API
of the InventorXt GUI component toolkit.")
(license license:bsd-3))))
+
+(define-public libdbusmenu-qt
+ (package
+ (name "libdbusmenu-qt")
+ (version "0.9.3+16.04.20160218-0ubuntu1")
+ (source
+ (origin
+ (method git-fetch)
+ ;; Download from github rather than launchpad because launchpad trunk
+ ;; tarball hash is not deterministic.
+ (uri (git-reference
+ (url "https://github.com/unity8-team/libdbusmenu-qt")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0b7ii1cvmpcyl79gqal9c3va9m55h055s4hx7fpxkhhqs9463ggg"))))
+ (build-system cmake-build-system)
+ (arguments
+ ;; XXX: Tests require a dbus session and some icons.
+ '(#:tests? #f))
+ (native-inputs
+ (list doxygen))
+ (inputs
+ (list qtbase-5))
+ (home-page "https://launchpad.net/libdbusmenu-qt")
+ (synopsis "Qt implementation of the DBusMenu spec")
+ (description "This library provides a Qt implementation of the DBusMenu
+protocol. The DBusMenu protocol makes it possible for applications to export
+and import their menus over DBus.")
+ (license license:lgpl2.1+)))
+
+(define-public kdsoap
+ (package
+ (name "kdsoap")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/KDAB/KDSoap/releases/download/"
+ "kdsoap-" version "/kdsoap-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1vh4rzb09kks1ilay1y60q7gf64gwzdwsca60hmx1xx69w8672fi"))))
+ (build-system qt-build-system)
+ (inputs `(("qtbase" ,qtbase-5)))
+ (arguments
+ '(#:configure-flags '("-DKDSoap_TESTS=true")
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" ;; These tests try connect to the internet.
+ "(kdsoap-webcalls|kdsoap-webcalls_wsdl|kdsoap-test_calc)"))
+ #t)))))
+ (home-page "https://www.kdab.com/development-resources/qt-tools/kd-soap/")
+ (synopsis "Qt SOAP component")
+ (description "KD SOAP is a tool for creating client applications for web
+services using the XML based SOAP protocol and without the need for a dedicated
+web server.")
+ (license (list license:gpl2 license:gpl3))))