summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 4625d2220d..5ce4220cb0 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -49,6 +49,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix build-system python)
#:use-module (guix build-system qt)
+ #:use-module (guix gexp)
#:use-module (guix packages)
#:use-module (guix deprecation)
#:use-module (guix utils)
@@ -169,9 +170,7 @@
(lambda* (#:key inputs #:allow-other-keys)
(substitute* "qt5ct.pro"
(("\\$\\$\\[QT_INSTALL_BINS\\]/lrelease")
- (string-append (assoc-ref inputs "qttools")
- "/bin/lrelease")))
- #t))
+ (search-input-file inputs "/bin/lrelease")))))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out")))
@@ -223,11 +222,11 @@ window managers, that don't provide Qt integration by themselves.")
(arguments
`(#:tests? #f ; No target
#:configure-flags
- (list
- (string-append "-DCMAKE_CXX_FLAGS=-I"
- (assoc-ref %build-inputs "qtbase")
- "/include/qt5/QtXkbCommonSupport/"
- ,(package-version qtbase-5)))))
+ ,#~(list
+ (string-append "-DCMAKE_CXX_FLAGS=-I"
+ #$(this-package-input "qtbase")
+ "/include/qt5/QtXkbCommonSupport/"
+ #$(package-version qtbase-5)))))
(native-inputs
`(("cmake-shared" ,cmake-shared)
("extra-cmake-modules" ,extra-cmake-modules)
@@ -1941,7 +1940,9 @@ using the Enchant spell-checking library.")
(invoke "qmake" "QT_BUILD_PARTS = libs tools" "--"
"--webengine-printing-and-pdf=no"
"--webengine-ffmpeg=system"
- "--webengine-icu=system"
+ ;; FIXME: Building qtwebengine 5.12.2 with
+ ;; icu4c >= 68 fails.
+ ;;"--webengine-icu=system"
"--webengine-pepper-plugins=no"
"-webengine-proprietary-codecs")))))
;; Tests are disabled due to "Could not find QtWebEngineProcess error"
@@ -2682,7 +2683,11 @@ different kinds of sliders, and much more.")
(sha256
(base32
"1rm9sjkabxna67dl7myx9d9vpdyfxfdhrk9w7b94srkkjbd2d8cw"))
- (patches (search-patches "qtwebkit-pbutils-include.patch"))))
+ (patches (search-patches "qtwebkit-pbutils-include.patch"
+ "qtwebkit-fix-building-with-bison-3.7.patch"
+ "qtwebkit-fix-building-with-glib-2.68.patch"
+ "qtwebkit-fix-building-with-icu-68.patch"
+ "qtwebkit-fix-building-with-python-3.9.patch"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)