summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm51
1 files changed, 33 insertions, 18 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 7ec4526492..d282dfcced 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -680,20 +680,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"-DFEATURE_system_sqlite=ON"
"-DFEATURE_system_xcb_xinput=ON"
;; Don't use the precompiled headers.
- "-DBUILD_WITH_PCH=OFF"
- ;; Drop special machine instructions that do not have runtime
- ;; detection.
- ,@(if (string-prefix? "x86_64"
- (or (%current-target-system)
- (%current-system)))
- '() ;implicitly enabled
- '("-DFEATURE_sse2=OFF"
- "-DFEATURE_sse3=OFF"
- "-DFEATURE_ssse3=OFF"
- "-DFEATURE_sse4_1=OFF"
- "-DFEATURE_sse4_2=OFF"))
- "-DFEATURE_mips_dsp=OFF"
- "-DFEATURE_mips_dspr2=OFF")))
+ "-DBUILD_WITH_PCH=OFF")))
((#:phases phases)
#~(modify-phases #$phases
(add-after 'unpack 'honor-CMAKE_PREFIX_PATH
@@ -876,7 +863,8 @@ developers using C++ or QML, a CSS & JavaScript like language.")
"tst_qfiledialog"
;; This test is susceptible to the 600 ms timeout used:
"tst_qpauseanimation")
- #$@(if (target-ppc64le?)
+ #$@(cond
+ ((target-ppc64le?)
#~((list
;; The 'tst_QPainter::fpe_radialGradients'
;; test fails with a 'Floating point
@@ -894,8 +882,30 @@ developers using C++ or QML, a CSS & JavaScript like language.")
;; "'Unable to fetch row' || 'database is
;; locked'" (see:
;; https://bugreports.qt.io/browse/QTBUG-117114).
- "tst_qsqlthread"))
- #~())) "|") ")")))))
+ "tst_qsqlthread")))
+ ((target-x86-32?)
+ #~((list
+ ;; QCOMPARE(qRound(actual), expected) returned TRUE
+ ;; unexpectedly.
+ "tst_qglobal"
+
+ ;; Actual (llMinDbl == llMin) : 0
+ ;; Expected (-9223372036854775807.0 ==
+ ;; Q_INT64_C(-9223372036854775807)) : 1
+ "tst_json"
+
+ ;; 'QVector3D::normal(QVector3D(), v1, v2) ==
+ ;; v3.normalized()' returned FALSE. ()
+ "tst_qvectornd"
+
+ ;; Actual (qRed(p)) : 11
+ ;; Expected (qGreen(p)): 10
+ "tst_qcolorspace"
+
+ ;; Actual (dv.validate(value, dummy)): Invalid
+ ;; Expected (standard_state) : Intermediate
+ "tst_qdoublevalidator")))
+ (else #~()))) "|") ")")))))
(replace 'patch-mkspecs
(lambda* (#:key outputs #:allow-other-keys)
(let* ((archdata (search-input-directory outputs "lib/qt6"))
@@ -2954,7 +2964,12 @@ linux/libcurl_wrapper.h")
(lambda _
;; Valid QT_BUILD_PARTS variables are:
;; libs tools tests examples demos docs translations
- (invoke "qmake" "QT_BUILD_PARTS = libs tools" "--"
+ (invoke "qmake"
+ #$@(if (target-x86-32?)
+ ;; Don't exhaust memory while linking.
+ #~("QMAKE_LFLAGS+=-Wl,--no-keep-memory -Wl,-z,now")
+ #~())
+ "QT_BUILD_PARTS = libs tools" "--"
"--webengine-printing-and-pdf=no"
"--webengine-ffmpeg=system"
;; FIXME: Building qtwebengine-5 5.12.2 with