summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm170
1 files changed, 112 insertions, 58 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 352f706b94..f97a2565e3 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -13,6 +13,7 @@
;;; Copyright © 2022 Greg Hogan <code@greghogan.com>
;;; Copyright © 2022 Ryan Tolboom <ryan@using.tech>
;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
+;;; Copyright © 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -80,6 +81,7 @@
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages ncurses)
#:use-module (gnu packages networking)
+ #:use-module (gnu packages openstack)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -87,6 +89,7 @@
#:use-module (gnu packages protobuf)
#:use-module (gnu packages pretty-print)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-check)
#:use-module (gnu packages python-science)
#:use-module (gnu packages python-web)
#:use-module (gnu packages python-xyz)
@@ -102,6 +105,7 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
+ #:use-module (gnu packages wxwidgets)
#:use-module (gnu packages xiph)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
@@ -215,49 +219,46 @@ mathematical operations, and much more.")
(license license:expat)))
(define-public rtl-sdr
- ;; No tagged release since 2018
- (let ((commit "5e73f90f1d85d8db2e583f3dbf1cff052d71d59b")
- (revision "1"))
- (package
- (name "rtl-sdr")
- (version (git-version "0.6.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.osmocom.org/rtl-sdr/")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "106fwzyr7cba952f3p3wm3hdqzm9zvm0v3gcz4aks2n7fnvrgrvn"))))
- (build-system cmake-build-system)
- (inputs
- (list libusb))
- (native-inputs
- (list pkg-config))
- (arguments
- `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
- "-DINSTALL_UDEV_RULES=ON")
- #:tests? #f ; No tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("DESTINATION \"/etc/udev/")
- (string-append "DESTINATION \""
- (assoc-ref outputs "out")
- "/lib/udev/")))))
- (add-after 'fix-paths 'fix-udev-rules
- (lambda _
- (substitute* "rtl-sdr.rules"
- ;; The plugdev group does not exist; use dialout as in
- ;; the hackrf package.
- (("GROUP=\"plugdev\"")
- "GROUP=\"dialout\"")))))))
- (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
- (synopsis "Software defined radio driver for Realtek RTL2832U")
- (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
+ (package
+ (name "rtl-sdr")
+ (version "2.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.osmocom.org/rtl-sdr/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z8dn0gdava894fb9fs9gcwvmik31fcj6ldkggylc0mhgw5145pr"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list libusb))
+ (native-inputs
+ (list pkg-config))
+ (arguments
+ `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
+ "-DINSTALL_UDEV_RULES=ON")
+ #:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION \"/etc/udev/")
+ (string-append "DESTINATION \""
+ (assoc-ref outputs "out")
+ "/lib/udev/")))))
+ (add-after 'fix-paths 'fix-udev-rules
+ (lambda _
+ (substitute* "rtl-sdr.rules"
+ ;; The plugdev group does not exist; use dialout as in
+ ;; the hackrf package.
+ (("GROUP=\"plugdev\"")
+ "GROUP=\"dialout\"")))))))
+ (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
+ (synopsis "Software defined radio driver for Realtek RTL2832U")
+ (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
cheap software defined radio, since the chip allows transferring the raw I/Q
samples to the host. @code{rtl-sdr} provides drivers for this purpose.
@@ -272,7 +273,7 @@ system configuration:
To install the rtl-sdr udev rules, you must extend 'udev-service-type' with
this package. E.g.: @code{(udev-rules-service 'rtl-sdr rtl-sdr)}")
- (license license:gpl2+))))
+ (license license:gpl2+)))
(define-public airspy
(let ((commit "6f92f47146aa8a8fce59b60927cf8c53da6851b3")
@@ -1198,7 +1199,7 @@ satellites.")
(define-public gqrx
(package
(name "gqrx")
- (version "2.16")
+ (version "2.17.3")
(source
(origin
(method git-fetch)
@@ -1207,7 +1208,7 @@ satellites.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "189cgmp88kabv823l5bfn1xfyyj6sldi5sdbmflvncxicf51b0yp"))))
+ (base32 "00pasp13gqglixl0iy9jb242vx1kczgpinjs3d8a1cl8yv5w6xkl"))))
(build-system qt-build-system)
(native-inputs
(list pkg-config))
@@ -1660,13 +1661,19 @@ instances over the network, and general QSO and DXpedition logging.")
(base32 "1lqd77v9xm58k9g9kfwxva3mmzm1yyk1v27nws5j1a293zfg2hkw"))))
(build-system qt-build-system)
(arguments
- (list #:tests? #f)) ; No test suite
+ (list #:tests? #f ; No test suite
+ #:configure-flags
+ (if (this-package-native-input "ruby-asciidoctor")
+ #~'()
+ #~(list "-DWSJT_GENERATE_DOCS=OFF"))))
(native-inputs
- (list asciidoc
- gfortran
- pkg-config
- qttools-5
- ruby-asciidoctor))
+ (append (list asciidoc
+ gfortran
+ pkg-config
+ qttools-5)
+ (if (supported-package? ruby-asciidoctor)
+ (list ruby-asciidoctor)
+ '())))
(inputs
(list boost
fftw
@@ -1912,7 +1919,7 @@ from devices on the 433 MHz, 868 MHz, 315 MHz, 345 MHz and 915 MHz ISM bands.")
(define-public multimon-ng
(package
(name "multimon-ng")
- (version "1.2.0")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -1921,7 +1928,7 @@ from devices on the 433 MHz, 868 MHz, 315 MHz, 345 MHz and 915 MHz ISM bands.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "0hm7391z1iz2sk4xkwfphqz8qvihqjzsh45csz14gb4jfs1p6ks2"))))
+ (base32 "1gd3kxb1w2fc6waa8g7af036yicjbg4a7hs0dgdci4d3aqwyz690"))))
(build-system cmake-build-system)
(inputs
(list libx11 pulseaudio))
@@ -2336,7 +2343,7 @@ defined radio with support for rtl-sdr.")
(define-public csdr
(package
(name "csdr")
- (version "0.18.1")
+ (version "0.18.2")
(source
(origin
(method git-fetch)
@@ -2345,7 +2352,7 @@ defined radio with support for rtl-sdr.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1vgl7d03khdql45jq5xxayqfhb5sasxhjmrl621gyk1k8kxaqs8a"))))
+ (base32 "0j5d64na47w1j1sprwj41d9dzvs2x7xwyp0pbl439g686iwp7m9d"))))
(build-system cmake-build-system)
(native-inputs
(list pkg-config))
@@ -2567,7 +2574,7 @@ voice formats.")
(define-public sdrangel
(package
(name "sdrangel")
- (version "7.16.0")
+ (version "7.17.0")
(source
(origin
(method git-fetch)
@@ -2576,7 +2583,7 @@ voice formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1c2pdxw2a3pysqlmr42gghg0ga33afwdp6wc97h7s6gwc5km6zlk"))))
+ (base32 "16hpnfzccpj8a3i24ryli870ym6kjih981sjapcqdc8va0q14qdz"))))
(build-system qt-build-system)
(native-inputs
(list doxygen graphviz pkg-config))
@@ -3089,6 +3096,53 @@ For example, it can decode the telemetry and images sent by some meteorological
satellites.")
(license license:gpl3)))
+(define-public chirp
+ (let ((commit "f59b5b254c33be55c73368d6ab036eaadd9e5e76")
+ (revision "1"))
+ (package
+ (name "chirp")
+ (version (git-version "0.4.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kk7ds/chirp")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s2qwz00nxqqfrs87ayjbdqg5i8mxf5xgxmqpincsn8rjxgw1s7x"))))
+ (build-system python-build-system)
+ (native-inputs
+ (list python-mock
+ python-mox3
+ python-pep8
+ python-pytest
+ python-pytest-mock
+ python-pyyaml
+ python-tox))
+ (inputs
+ (list python-future
+ python-importlib-resources
+ python-pyserial
+ python-requests
+ python-six
+ python-wxpython
+ python-yattag))
+ (arguments
+ (list ;; FIXME: How to run the tests? The default way crashes.
+ #:tests? #f
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'set-home-for-tests
+ (lambda _
+ (setenv "HOME" "/tmp"))))))
+ (synopsis "Cross-radio programming tool")
+ (description "Chirp is a cross-radio programming tool. It supports a
+growing list of radios across several manufacturers and allows transferring of
+memory contents between them.")
+ (home-page "https://chirp.danplanet.com")
+ (license license:gpl3+))))
+
(define-public qdmr
(package
(name "qdmr")