summaryrefslogtreecommitdiff
path: root/gnu/packages/radio.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/radio.scm')
-rw-r--r--gnu/packages/radio.scm335
1 files changed, 239 insertions, 96 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index ccfa77850b..a459367aec 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -2,12 +2,14 @@
;;; Copyright © 2017, 2018, 2019, 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019, 2020 Christopher Howard <christopher@librehacker.com>
;;; Copyright © 2019, 2020 Evan Straw <evan.straw99@gmail.com>
-;;; Copyright © 2020, 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2020, 2021, 2022 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2020 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2020 Charlie Ritter <chewzerita@posteo.net>
;;; Copyright © 2020, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2021 João Pedro Simas <jpsimas@gmail.com>
;;; Copyright © 2021 Jack Hill <jackhill@jackhill.us>
+;;; Copyright © 2022 Jai Vetrivelan <jaivetrivelan@gmail.com>
+;;; Copyright © 2022 Sheng Yang <styang@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -133,7 +135,7 @@ useful in modems implemented with @dfn{digital signal processing} (DSP).")
(define-public liquid-dsp
(package
(name "liquid-dsp")
- (version "1.3.2")
+ (version "1.4.0")
(source
(origin (method git-fetch)
(uri (git-reference
@@ -141,7 +143,7 @@ useful in modems implemented with @dfn{digital signal processing} (DSP).")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n6dbg13q8ga5qhg1yiszwly4jj0rxqr6f1xwm9waaly5z493xsd"))))
+ (base32 "0mr86z37yycrqwbrmsiayi1vqrgpjq0pn1c3p1qrngipkw45jnn0"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake))
@@ -169,41 +171,49 @@ mathematical operations, and much more.")
(license license:expat)))
(define-public rtl-sdr
- (package
- (name "rtl-sdr")
- (version "0.6.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.osmocom.org/rtl-sdr/")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0lmvsnb4xw4hmz6zs0z5ilsah5hjz29g1s0050n59fllskqr3b8k"))))
- (build-system cmake-build-system)
- (inputs
- (list libusb))
- (native-inputs
- (list pkg-config))
- (arguments
- `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
- "-DINSTALL_UDEV_RULES=ON")
- #:tests? #f ; No tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-paths
- (lambda* (#:key outputs #:allow-other-keys)
- (substitute* "CMakeLists.txt"
- (("DESTINATION \"/etc/udev/")
- (string-append "DESTINATION \""
- (assoc-ref outputs "out")
- "/lib/udev/")))
- #t)))))
- (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
- (synopsis "Software defined radio driver for Realtek RTL2832U")
- (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
+ ;; No tagged release since 2018
+ (let ((commit "5e73f90f1d85d8db2e583f3dbf1cff052d71d59b")
+ (revision "1"))
+ (package
+ (name "rtl-sdr")
+ (version (git-version "0.6.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.osmocom.org/rtl-sdr/")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "106fwzyr7cba952f3p3wm3hdqzm9zvm0v3gcz4aks2n7fnvrgrvn"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list libusb))
+ (native-inputs
+ (list pkg-config))
+ (arguments
+ `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON"
+ "-DINSTALL_UDEV_RULES=ON")
+ #:tests? #f ; No tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION \"/etc/udev/")
+ (string-append "DESTINATION \""
+ (assoc-ref outputs "out")
+ "/lib/udev/")))))
+ (add-after 'fix-paths 'fix-udev-rules
+ (lambda _
+ (substitute* "rtl-sdr.rules"
+ ;; The plugdev group does not exist; use dialout as in
+ ;; the hackrf package.
+ (("GROUP=\"plugdev\"")
+ "GROUP=\"dialout\"")))))))
+ (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
+ (synopsis "Software defined radio driver for Realtek RTL2832U")
+ (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
cheap software defined radio, since the chip allows transferring the raw I/Q
samples to the host. @code{rtl-sdr} provides drivers for this purpose.
@@ -218,7 +228,7 @@ system configuration:
To install the rtl-sdr udev rules, you must extend 'udev-service-type' with
this package. E.g.: @code{(udev-rules-service 'rtl-sdr rtl-sdr)}")
- (license license:gpl2+)))
+ (license license:gpl2+))))
(define-public airspyhf
(package
@@ -270,7 +280,7 @@ with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
(define-public soapysdr
(package
(name "soapysdr")
- (version "0.8.0")
+ (version "0.8.1")
(source
(origin
(method git-fetch)
@@ -279,7 +289,7 @@ with this package. E.g.: @code{(udev-rules-service 'airspyhf airspyhf)}")
(commit (string-append "soapy-sdr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1dy25zxk7wmg7ik82dx7h3bbbynvalbz1dxsl7kgm3374yxhnixv"))))
+ (base32 "19f2x0pkxvf9figa0pl6xqlcz8fblvqb19mcnj632p0l8vk6qdv2"))))
(build-system cmake-build-system)
(native-inputs
(list python swig))
@@ -320,32 +330,28 @@ SoapySDR library.")
(license license:expat)))
(define-public soapyhackrf
- ;; Use commit because some fixes are not in a release yet
- ;; (last release was in 2018).
- (let ((commit "8d2e7beebb4c451609cb0cee236fa4d20a0e28b1")
- (revision "2"))
- (package
- (name "soapyhackrf")
- (version (git-version "0.3.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/pothosware/SoapyHackRF")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0l5890a240i1fan88jjdxaqswk3as410nlrv12a698fy9npqh4w4"))))
- (build-system cmake-build-system)
- (inputs
- (list hackrf soapysdr))
- (arguments
- `(#:tests? #f)) ; No test suite
- (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
- (synopsis "SoapySDR HackRF module")
- (description
- "This package provides HackRF devices support to the SoapySDR library.")
- (license license:expat))))
+ (package
+ (name "soapyhackrf")
+ (version "0.3.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pothosware/SoapyHackRF")
+ (commit (string-append "soapy-hackrf-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0wnnsm3c4ivwcbs1b68svbyds13aajws9mqk2xjc2pqgj0fdhcvz"))))
+ (build-system cmake-build-system)
+ (inputs
+ (list hackrf soapysdr))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://github.com/pothosware/SoapyHackRF/wiki")
+ (synopsis "SoapySDR HackRF module")
+ (description
+ "This package provides HackRF devices support to the SoapySDR library.")
+ (license license:expat)))
(define-public soapyrtlsdr
(package
@@ -374,14 +380,14 @@ SoapySDR library.")
(define-public chirp
(package
(name "chirp")
- (version "20211016")
+ (version "20220118")
(source
(origin
(method url-fetch)
(uri (string-append "https://trac.chirp.danplanet.com/chirp_daily/daily-"
version "/chirp-daily-" version ".tar.gz"))
(sha256
- (base32 "13xzqnhvnw6yipv4izkq0s9ykyl9pc5ifpr1ii8xfp28ch706qyw"))))
+ (base32 "0q2ifmprxqqxnww8fx8fjmm2lv9vdv6xzsk1ysa27fb290vgyawn"))))
(build-system python-build-system)
(inputs
(list python2-libxml2 python2-pygtk python2-pyserial))
@@ -397,8 +403,8 @@ memory contents between them.")
(define-public aptdec
;; No release since 2013, use commit directly.
- (let ((commit "5f91799637d93dfe7791caa7e9a6683050c4f8f3")
- (revision "1"))
+ (let ((commit "51405971fd4e97714d1e987269e49c6edfe4e0da")
+ (revision "2"))
(package
(name "aptdec")
(version (git-version "1.7" revision commit))
@@ -410,7 +416,7 @@ memory contents between them.")
(commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0i7vkjjrq392gs9qaibr7j3v4hijqqg8458dn21dwh16ncrvr9bp"))))
+ (base32 "0fzkhqnbkc2dd39jzb5m5mwcl31b0x3w0yykpx4s195llq4bdvis"))))
(build-system cmake-build-system)
(inputs
(list libpng libsndfile))
@@ -428,7 +434,7 @@ and a dedicated receiver.")
(define-public redsea
(package
(name "redsea")
- (version "0.18")
+ (version "0.20")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -437,7 +443,7 @@ and a dedicated receiver.")
(file-name (git-file-name name version))
(sha256
(base32
- "1y96g0ra2krjb2kypm8s5gdfia45yci4f36klsvyzg8d53v5cwhn"))))
+ "1bx4l87vz935cj5hapdh1dkjlmlfg73cgsjaf27314n7p4xkv50v"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -822,7 +828,7 @@ satellites.")
(define-public gqrx
(package
(name "gqrx")
- (version "2.15.4")
+ (version "2.15.8")
(source
(origin
(method git-fetch)
@@ -831,7 +837,7 @@ satellites.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0r5pdj2l6zs2zvkc1bd7kg9vzx25pcgiw025n5yc841m8yg6n2c9"))))
+ (base32 "1ph7fnjxfv7rfdlh17c8j4djvkfqjnalmcvnafhnq7agjy428727"))))
(build-system qt-build-system)
(native-inputs
(list pkg-config))
@@ -901,7 +907,7 @@ hardware.")
(define-public flrig
(package
(name "flrig")
- (version "1.3.52")
+ (version "1.4.04")
(source
(origin
(method git-fetch)
@@ -910,12 +916,12 @@ hardware.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0vxn1wy5b2zfq20k93rfgq34m1nd3mxd74h8l98f90d85fhcqggy"))))
+ (base32 "06alzln46x08110v1ghasphr2mmznzk0x5h59vl9g2w1z12i9zsm"))))
(build-system gnu-build-system)
(native-inputs
(list autoconf automake pkg-config))
(inputs
- (list fltk libx11 libxext libxfixes libxft))
+ (list eudev fltk libx11 libxext libxfixes libxft))
(synopsis "Radio transceiver control program")
(description
"Flrig is a transceiver control program for amateur radio use.
@@ -949,6 +955,32 @@ or USB connection.")
(home-page "http://www.w1hkj.com/")
(license license:gpl3+)))
+(define-public flmsg
+ (package
+ (name "flmsg")
+ (version "4.0.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.code.sf.net/p/fldigi/flmsg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "157s6mvky9h094hkncm47964qh0bnwg0m2rw3wx0qj1mh5isxv4j"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ (list autoconf automake pkg-config))
+ (inputs
+ (list fltk libx11 libxext libxfixes libxft))
+ (synopsis "NBEMS messaging system")
+ (description
+ "FLMSG is a Narrow Band Emergency Messaging Software (NBEMS).
+It can be used to manage, send and receive the forms that are used as basis
+for emergency communications data transfers (like ICS213 forms).")
+ (home-page "http://www.w1hkj.com/")
+ (license license:gpl3+)))
+
(define-public flwrap
(package
(name "flwrap")
@@ -1029,7 +1061,7 @@ you must extend 'udev-service-type' with this package. E.g.:
(define-public hamlib
(package
(name "hamlib")
- (version "4.3.1")
+ (version "4.4")
(source
(origin
(method url-fetch)
@@ -1037,7 +1069,7 @@ you must extend 'udev-service-type' with this package. E.g.:
"https://github.com/Hamlib/Hamlib/releases/download/"
version "/hamlib-" version ".tar.gz"))
(sha256
- (base32 "0c578m04zs8dllbd4cv6nxb44y0dn8kiapzkih84ycfjzmnkhdrl"))))
+ (base32 "11r4i8gmxnb6ixpk4ns38c9xwj3qibp2v3pkhy2z0lhz0xxi1w4b"))))
(build-system gnu-build-system)
(native-inputs
(list doxygen
@@ -1091,6 +1123,30 @@ users.")
"--with-tcl-binding"
"--with-xml-support")))))
+(define-public jtdx-hamlib
+ ;; Fork of hamlib with custom patches used by jtdx.
+ (package
+ (inherit hamlib)
+ (name "jtdx-hamlib")
+ (version "2.2.158")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtdx-project/jtdxhamlib.git")
+ (commit "158")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0m9i5k1n6j0nvmsqcy12x2ngqzjvxxlc3jg29igh93hb7lprlkjv"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs hamlib)
+ (prepend autoconf automake libtool texinfo)))
+ (arguments
+ `(#:configure-flags '("--disable-shared"
+ "--enable-static"
+ "--without-cxx-binding"
+ "--disable-winradio")))))
+
(define-public tlf
(package
(name "tlf")
@@ -1150,7 +1206,7 @@ instances over the network, and general QSO and DXpedition logging.")
(define-public wsjtx
(package
(name "wsjtx")
- (version "2.5.2")
+ (version "2.5.4")
(source
(origin
(method git-fetch)
@@ -1159,7 +1215,7 @@ instances over the network, and general QSO and DXpedition logging.")
(commit (string-append "wsjtx-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "01346f2x3jc0gbzdi7ihzr9rxibnbzn31ix0879qfavrv8l31k1s"))))
+ (base32 "0nciw9smrfcsirlwyny5r9h7sk2zvm40m56y1hxpgpmbnh6mqikh"))))
(build-system qt-build-system)
(native-inputs
(list asciidoc gfortran pkg-config qttools ruby-asciidoctor))
@@ -1184,6 +1240,47 @@ weak-signal conditions.")
(home-page "https://www.physics.princeton.edu/pulsar/k1jt/wsjtx.html")
(license license:gpl3)))
+(define-public jtdx
+ (package
+ (name "jtdx")
+ (version "2.2.158")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jtdx-project/jtdx")
+ (commit "158")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1lw9q7ggh2jlasipl3v5pkbabysjr6baw15lnmg664ah3fwdrvnx"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list asciidoc gfortran pkg-config qttools ruby-asciidoctor))
+ (inputs
+ (list
+ boost
+ fftw
+ fftwf
+ jtdx-hamlib
+ libusb
+ qtbase-5
+ qtwebsockets
+ qtmultimedia
+ qtserialport))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (synopsis "Weak-signal ham radio communication program, forked from WSJTX")
+ (description
+ "JTDX means \"JT,T10 and FT8 and FT4 modes for DXing\", it is being
+developed with main focus on the sensitivity and decoding efficiency, both, in
+overcrowded and half empty HF band conditions.
+
+It is modified WSJT-X software forked from WSJT-X r6462. JTDX supports JT9,
+JT65, T10, FT8 and FT4 © digital modes for HF amateur radio communication,
+focused on DXing and being shaped by community of DXers.JTDX")
+ (home-page "https://www.jtdx.tech/en/")
+ (license license:gpl3)))
+
(define-public js8call
(package
(inherit wsjtx)
@@ -1246,19 +1343,39 @@ operators.")
(define-public xnec2c
(package
(name "xnec2c")
- (version "4.2")
+ (version "4.4.5")
(source
(origin
(method url-fetch)
- (uri (string-append "http://www.5b4az.org/pkg/nec2/xnec2c/xnec2c-"
- version ".tar.bz2"))
+ (uri (string-append "https://www.xnec2c.org/releases/xnec2c-v"
+ version ".tar.gz"))
(sha256
- (base32 "0jprahww6jvwq616lkq80sac166ffy0fp83gr5kvjc9k4pcls00n"))))
+ (base32 "0v3qr16d42jri2vwwgrhhknaypdcjyn6ccdjpqfzr8zzr33z5pca"))))
(build-system gnu-build-system)
(native-inputs
- (list pkg-config))
+ (list autoconf
+ automake
+ gettext-minimal
+ `(,glib "bin")
+ libtool
+ pkg-config))
(inputs
- (list gtk+))
+ (list gtk+ openblas))
+ (arguments
+ `(#:configure-flags
+ ,#~(list (string-append "--with-openblas-incdir="
+ #$(this-package-input "openblas")
+ "/include"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'fix-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/Makefile.am"
+ (("\\$\\(GLIB_COMPILE_RESOURCES\\)")
+ (search-input-file inputs "bin/glib-compile-resources")))
+ (substitute* "src/mathlib.c"
+ (("libopenblas\\.so")
+ (search-input-file inputs "lib/libopenblas.so"))))))))
(synopsis "Antenna modeling software")
(description
"Xnec2c is a GTK3-based graphical version of nec2c, a translation to the
@@ -1266,13 +1383,13 @@ C language of NEC2, the FORTRAN Numerical Electromagnetics Code commonly used
for antenna simulation and analysis. It can be used to define the geometry of
an antenna, and then plot the radiation pattern or frequency-related data like
gain and standing wave ratio.")
- (home-page "http://www.5b4az.org/")
+ (home-page "https://www.xnec2c.org/")
(license license:gpl3+)))
(define-public dump1090
(package
(name "dump1090")
- (version "6.1")
+ (version "7.1")
(source
(origin
(method git-fetch)
@@ -1281,7 +1398,7 @@ gain and standing wave ratio.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "13ssp2c3s18rszpmm3rpvicqvgvfiirsjf294m6r1sf3ji7ygd9q"))))
+ (base32 "1702qv5g27sgpqf98sj2qbg36sqzc7r3kssslzzgljqkr5jgrw6m"))))
(build-system gnu-build-system)
(native-inputs
(list pkg-config))
@@ -1541,6 +1658,32 @@ programs using the library: cw, cwgen, cwcp and xcwcp. The programs are
intended for people who want to learn receiving and sending morse code.")
(license license:gpl2+)))
+(define-public kochmorse
+ (package
+ (name "kochmorse")
+ (version "3.5.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/hmatuschek/kochmorse")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1s1aj223n57rpc95rih98z08xnyhq2zp02byzrc3f7s01fv3nj0l"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list qttools))
+ (inputs
+ (list qtbase-5 qtmultimedia))
+ (arguments
+ `(#:tests? #f)) ; No test suite
+ (home-page "https://dm3mat.darc.de/kochmorse/")
+ (synopsis "Morse code tutor")
+ (description
+ "KochMorse is a simple morse-code tutor using the Koch method.")
+ (license license:gpl2+)))
+
(define-public gnuais
(package
(name "gnuais")
@@ -1690,7 +1833,7 @@ receiver.")
(define-public welle-io
(package
(name "welle-io")
- (version "2.3")
+ (version "2.4")
(source
(origin
(method git-fetch)
@@ -1699,7 +1842,7 @@ receiver.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1xl1lanw0xgmgks67dbfb2h52jxnrd1i2zik56v0q8dwsr7f0daw"))))
+ (base32 "0vl98pciw6xzcxyprcb4613rxn0i202f104lmy900jrny0pq4y65"))))
(build-system qt-build-system)
(native-inputs
(list pkg-config))
@@ -1911,7 +2054,7 @@ voice formats.")
(define-public sdrangel
(package
(name "sdrangel")
- (version "6.17.5")
+ (version "6.18.1")
(source
(origin
(method git-fetch)
@@ -1920,7 +2063,7 @@ voice formats.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1g9972q78nxl62hpyn029s85ny5jj9dxlmmfqyz3l9sd6kdv9kl6"))))
+ (base32 "17lakqy55p481fa5w6ylh79xbd4rdiqk9y21vmi4m2r4wx893zw1"))))
(build-system qt-build-system)
(native-inputs
(list doxygen graphviz pkg-config))