summaryrefslogtreecommitdiff
path: root/gnu/packages/rails.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rails.scm')
-rw-r--r--gnu/packages/rails.scm95
1 files changed, 95 insertions, 0 deletions
diff --git a/gnu/packages/rails.scm b/gnu/packages/rails.scm
new file mode 100644
index 0000000000..e1e14f5b70
--- /dev/null
+++ b/gnu/packages/rails.scm
@@ -0,0 +1,95 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2016 Matthew Jordan <matthewjordandevops@yandex.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages rails)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (gnu packages ruby)
+ #:use-module (guix build-system ruby))
+
+(define-public ruby-spring
+ (package
+ (name "ruby-spring")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/rails/spring/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0czc4mkwfngcqmna49a0l98f6wlhdq2i8gwr63lrmk90d9k25x1n"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "test:unit"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'remove-bump
+ (lambda _
+ (substitute* "spring.gemspec"
+ (("gem.add_development_dependency 'bump'") ""))
+ (substitute* "Rakefile"
+ (("require \\\"bump/tasks\\\"") ""))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-activesupport" ,ruby-activesupport)))
+ (synopsis "Ruby on Rails application preloader")
+ (description
+ "Spring is a Ruby on Rails application preloader. It speeds up
+development by keeping your application running in the background so the
+application does need to boot it every time you run a test, rake task or
+migration.")
+ (home-page "https://github.com/rails/spring")
+ (license license:expat)))
+
+(define-public ruby-debug-inspector
+ (package
+ (name "ruby-debug-inspector")
+ (version "0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "debug_inspector" version))
+ (sha256
+ (base32
+ "109761g00dbrw5q0dfnbqg8blfm699z4jj70l4zrgf9mzn7ii50m"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (and
+ (zero? (system* "rake" "compile"))
+ (zero?
+ (system*
+ "ruby" "-Ilib" "-e"
+ (string-append
+ "require 'debug_inspector'; RubyVM::DebugInspector."
+ "open{|dc| p dc.backtrace_locations}")))))))))
+ (synopsis "Ruby wrapper for the MRI 2.0 debug_inspector API")
+ (description
+ "This package provides a Ruby wrapper for the MRI 2.0 debug_inspector
+API.")
+ (home-page
+ "https://github.com/banister/debug_inspector")
+ (license license:expat)))