summaryrefslogtreecommitdiff
path: root/gnu/packages/rsync.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/rsync.scm')
-rw-r--r--gnu/packages/rsync.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index 5f549ef234..98cd33baef 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -29,6 +29,7 @@
#:use-module (gnu packages digest)
#:use-module (gnu packages perl)
#:use-module (gnu packages popt)
+ #:use-module (gnu packages tls)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix download)
@@ -39,27 +40,26 @@
(define-public rsync
(package
(name "rsync")
- (version "3.2.5")
+ (version "3.2.6")
(source (origin
(method url-fetch)
(uri (string-append "https://rsync.samba.org/ftp/rsync/src/rsync-"
version ".tar.gz"))
(sha256
(base32
- "1flsqq01dmbz0m2vwn4sj46zb9yxlrfc6xy3gf393xyd6lbd5i1a"))))
+ "1lslaj1s7mpgf4v5lxhhiyy4ffmxaxy9cbplx8gx8dvqnax6aczv"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
;; The bundled copies are preferred by default.
(list "--without-included-zlib"
- "--without-included-popt"
- ;; Avoid these dependencies for now.
- "--disable-openssl")))
+ "--without-included-popt")))
(native-inputs
(list perl))
(inputs
(list acl
lz4
+ openssl
popt
xxhash
zlib