summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm23
1 files changed, 12 insertions, 11 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 2dc7b988c1..1ae8341f6b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7469,20 +7469,21 @@ Ruby's large and slower test/unit.")
;; Rebuilding the gemspec seems to require git, even though this is not a
;; git repository, so we just build the gem from the existing gemspec.
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-test
- (lambda -
- (substitute* "tests/hsl_triple_test.rb"
- (("0\\\\\\.0%")
- "0\\.?0?%"))))
- (replace 'build
- (lambda _
- (invoke "gem" "build" "term-ansicolor.gemspec"))))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-test
+ (lambda -
+ (substitute* "tests/hsl_triple_test.rb"
+ (("0\\\\\\.0%")
+ "0\\.?0?%"))))
+ (replace 'build
+ (lambda _
+ (invoke "gem" "build" "term-ansicolor.gemspec"))))))
(propagated-inputs
(list ruby-tins))
(native-inputs
- (list ruby-gem-hadar ruby-minitest-tu-shim))
+ (list ruby-gem-hadar))
(synopsis "Ruby library to control the attributes of terminal output")
(description
"This Ruby library uses ANSI escape sequences to control the attributes