summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 71c93c0c8d..81269d28d9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7,7 +7,7 @@
;;; Copyright © 2015, 2016, 2017 Ben Woodcroft <donttrustben@gmail.com>
;;; Copyright © 2017 Nikita <nikita@n0.is>
;;; Copyright © 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
;;; Copyright © 2017, 2018, 2019 Christopher Baines <mail@cbaines.net>
@@ -1117,7 +1117,7 @@ line of code.")
#t))
(add-after 'unpack 'patch-pandoc-path
(lambda* (#:key inputs #:allow-other-keys)
- (let ((pandoc (string-append (assoc-ref inputs "ghc-pandoc")
+ (let ((pandoc (string-append (assoc-ref inputs "pandoc")
"/bin/pandoc")))
(substitute* "lib/pandoc-ruby.rb"
(("@@pandoc_path = 'pandoc'")
@@ -1137,7 +1137,7 @@ line of code.")
(native-inputs
`(("ruby-mocha" ,ruby-mocha)))
(inputs
- `(("ghc-pandoc" ,ghc-pandoc)))
+ `(("pandoc" ,pandoc)))
(synopsis "Ruby wrapper for Pandoc")
(description "PandocRuby is a wrapper for Pandoc, a Haskell library with
command line tools for converting one markup format to another. Pandoc can
@@ -6745,7 +6745,7 @@ inspired by the Sinatra microframework style of specifying actions:
(define-public ruby-rubocop-ast
(package
(name "ruby-rubocop-ast")
- (version "0.1.0")
+ (version "0.3.0")
(source
(origin
(method git-fetch) ;no test suite in distributed gem
@@ -6755,7 +6755,7 @@ inspired by the Sinatra microframework style of specifying actions:
(file-name (git-file-name name version))
(sha256
(base32
- "0nz25z5b76xkgb9sh370hni3l946j07fr05cdwkdj9x7ibgsb6nj"))))
+ "1ycf6qcj8nbzk2js72priim4642lkn56w5kbny1nlryjkckxgm04"))))
(build-system ruby-build-system)
(arguments
`(#:test-target "spec"