summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm29
1 files changed, 5 insertions, 24 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 59370447b2..73eefe8dde 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -426,13 +426,13 @@ expectations and mocks frameworks.")
(define-public bundler
(package
(name "bundler")
- (version "1.14.4")
+ (version "1.14.5")
(source (origin
(method url-fetch)
(uri (rubygems-uri "bundler" version))
(sha256
(base32
- "1hafmb7p41pm40a2z7f4x5zpgrb72xvgwlvkxnflmzqkvq2prkfv"))))
+ "0635s6naz9hn4iqbvkhnm1by4j4spvv13mb7nzwwimnpbqgx663i"))))
(build-system ruby-build-system)
(arguments
'(#:tests? #f)) ; avoid dependency cycles
@@ -1020,26 +1020,6 @@ features.")
(home-page "https://github.com/chneukirchen/bacon")
(license license:expat)))
-(define-public ruby-arel
- (package
- (name "ruby-arel")
- (version "6.0.0")
- (source (origin
- (method url-fetch)
- (uri (rubygems-uri "arel" version))
- (sha256
- (base32
- "18wnfnzr2i5p3fygsddjbi1cimws6823nbk8drxidmnj8jz7h0ar"))))
- (build-system ruby-build-system)
- (arguments
- '(#:tests? #f)) ; no test suite
- (synopsis "SQL AST manager for Ruby")
- (description "Arel is a SQL AST manager for Ruby. It simplifies the
-generation of complex SQL queries and adapts to various relational database
-implementations.")
- (home-page "https://github.com/rails/arel")
- (license license:expat)))
-
(define-public ruby-connection-pool
(package
(name "ruby-connection-pool")
@@ -1854,8 +1834,9 @@ net/http library.")
(arguments '(#:tests? #f)) ; no tests
(home-page "https://github.com/rails/arel")
(synopsis "SQL AST manager for Ruby")
- (description "Arel is a SQL AST manager for Ruby. It simplifies the
-generation of complex SQL queries and is compatible with various RDBMSes.")
+ (description "Arel is an SQL @dfn{Abstract Syntax Tree} (AST) manager for
+Ruby. It simplifies the generation of complex SQL queries and adapts to
+various relational database implementations.")
(license license:expat)))
(define-public ruby-minitar