summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 5361f23e59..cb113e8d9c 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -326,11 +326,12 @@ mashups, office (web agendas, mail clients, ...), etc.")
;; No `configure' script; run "make check" after "make install" as
;; prescribed by README.
- #:phases (alist-cons-after
- 'install 'check
- (assoc-ref %standard-phases 'check)
- (fold alist-delete %standard-phases
- '(configure check)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'check)
+ (add-after 'install 'check
+ (assoc-ref %standard-phases 'check)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "PLATFORM=linux"