summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index cb113e8d9c..b8b2dbacab 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -331,7 +331,14 @@ mashups, office (web agendas, mail clients, ...), etc.")
(delete 'configure)
(delete 'check)
(add-after 'install 'check
- (assoc-ref %standard-phases 'check)))
+ (assoc-ref %standard-phases 'check))
+ (add-after 'unpack 'disable-broken-tests
+ (lambda _
+ ;; The port tests fail with this error:
+ ;; Error: (line 294) invalid escape-sequence '\x o'
+ (substitute* "tests/runtests.sh"
+ (("\\$interpret -s port-tests\\.scm") ""))
+ #t)))
#:make-flags (let ((out (assoc-ref %outputs "out")))
(list "PLATFORM=linux"