summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm16
1 files changed, 5 insertions, 11 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index c43d17219e..ea1adb99ee 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015, 2016, 2018, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
@@ -126,10 +126,6 @@
(("\\./configure")
(string-append (which "sh") " configure")))
#t))
- ;; FIXME: the texlive-union insists on regenerating fonts. It stores
- ;; them in HOME, so it needs to be writeable.
- (add-before 'build 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t))
(replace 'build
(lambda* (#:key system outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
@@ -177,8 +173,8 @@
("autoconf" ,autoconf)
("automake" ,automake)
("libtool" ,libtool)
- ("texlive" ,(texlive-union (list texlive-tex-texinfo
- texlive-epsf)))
+ ("texlive" ,(texlive-updmap.cfg (list texlive-tex-texinfo
+ texlive-epsf)))
("texinfo" ,texinfo)
("ghostscript" ,ghostscript)
("m4" ,m4)))
@@ -628,8 +624,7 @@ utility functions for all standard Scheme implementations.")
(replace 'build
(lambda* (#:key inputs outputs #:allow-other-keys)
(setenv "SCHEME_LIBRARY_PATH"
- (string-append (assoc-ref inputs "slib")
- "/lib/slib/"))
+ (search-input-directory inputs "lib/slib"))
(invoke "make" "scmlit" "CC=gcc")
(invoke "make" "all")))
(add-after 'install 'post-install
@@ -639,8 +634,7 @@ utility functions for all standard Scheme implementations.")
(delete-file req)
(format (open req (logior O_WRONLY O_CREAT))
"(define (library-vicinity) ~s)\n"
- (string-append (assoc-ref inputs "slib")
- "/lib/slib/"))
+ (search-input-directory inputs "lib/slib"))
;; We must generate the slibcat file.
(invoke (string-append out "/bin/scm")